Gaming Service issue - Again - it's an absolute disaster

If you think of MSFS as an MMO, it will make more sense to you.”

What does this cryptic statement mean? It would be helpful if you could explain it,
then everyone here will benefit from your knowledge. It’s a forum to help other members,
not to spread puzzles.

It’s not a puzzle. MSFS is ostensibly a massively multiplayer online experience. Whether you want to or not, the sim has the ability to connect you to other peoples clients. You see their planes in the world.

The clients all have to be running the same client version for them to communicate. MMO games will require a client update when a new version is released. You don’t get to opt out of that, or rather you can but then you can’t connect to the game world.

This isn’t any different in that regard.

Do you see now?

Per Wikipedia:
A massively multiplayer online game (MMOG or more commonly MMO ) is an online video game with a large numbers of players, often hundreds or thousands, on the same server.

I didn’t know that there was that many simmers who were flying “Multiplayer”.

MSFS has sold millions, so globally there are a lot of people online.

However, the salient point is not the number of people online, but that the client has to be running the latest code to go online. I’m sure some of us have experienced that state where the sim has not updated, but it manages to launch anyway. You find many features are greyed out, like the Marketplace.

If there is a MSFS system update (forced update: “checking for updates”), MSFS will only launch after downloading this update. The game won’t “launch anyway”. This ensures that all gamers have the same version and not different ones, because some user have updated and some not.
If the Market Place function is greyed out, then you are not connected to the MSFS account.

More likely “you” simply have the wrong client version. I’ve seen that before myself once. Somehow the sim managed to skip over the update check. This was pretty early on though, maybe early 2021.

I’ve got a feeling this may be more specific to gamepass games?

I’ve had this happen to both halo and total war which I own through gamepass, but never to MSFS which I purchased.

I agree it’s a total PITA though, I’ve sometimes had success with recommended steps and sometimes even a full install in place doesn’t fix it and I simply need to re-install the games in their entirety.

Interested if it’s affected people here on just the game pass version or also purchased copies?


Go to
Options > general options > data
Turn off online functionality
apply and save

Turn on online functionality
apply and save

Hi guys, just to say I had this issue for the first time last week. I was taken to a blank “game servics” page in MS store, tried logging in and out of MS store and Xbox, restarting etc with no luck.

What did work was changing my Windows 10 account type to administrator. I was then able to run the game as normal, and it seems to have triggered whatever background update was needed because I have since been able to revert to a standard user account without issues.

Today is the first time I have ever experienced this issue (owned MSFS since day 1). I have repaired/reset the MS Store, Xbox, and Gaming Services apps, restarted my PC (Windows 10) multiple times, and found my account is already set to Administrator. I have tried to start MSFS from the Start menu, Xbox app, and MS Store with the same result - MS Store Gaming Services app page.

I really hope I’m not forced to uninstall and reinstall.

The Windows App Settings for Microsoft Flight Simulator says “Loading” and 7/8/2022. I think most other apps showed install size, but now many also show “Loading”.

Initial launch of MSFS today got as far as the Asobo splash screen and update bar, but never proceeded past 0%. Eventually closed out figuring the servers were busy… now when I try to launch MSFS the MS Store pops up to the “Gaming Services” page. I’ve tried repairing gaming services from Add or Remove Programs, and tried uninstalling / reinstalling the Gaming Services package via getappxpackage, but it doesn’t seem to be helping. Anyone have any suggestions?

Fixed it… uninstalled MSFS from Add or Remove Programs. Logged out of the Microsoft Store. Ran wsreset.exe to reset the Microsoft Store. Rebooted. Logged back into the Store, and reinstalled MSFS. It started and allowed me to set the install directory back to my normal location then downloaded 50 gigs of update.

I experienced exactly the same issue (Store version on PC) and descended into that extremely frustrating Gaming Services - XBox perpetual loop and not finding a way out of that for 20 minutes I was about to take drastic action (like chuck the PC out of the window). I had waited until 21.00Z to, hopefully, miss the early downloaders traffic jam on the servers, so discounted that as a significant factor. Eventually, by selecting the Sim in the XBox app then ‘Manage’ from there. In the drop down menu selecting ‘Check for Updates’ and on the subsequent drop down from there selecting ‘Verify & Repair’ I jumped straight to the active download in the XBox app. Went to bed, slept, got up this morning - all done and seems to be functioning just fine.

It seems to me as if there might have been a corruption to a file in that initial download path.

What annoys me intensely is that after all this time there is still not a consistent methodology for downloading these updates. I appreciate that there are millions of users with probably tens if not hundreds of thousands of different hardware/software configurations but even so, how hard can it be to have an approach that is repeatable?

Looking at the forum this morning it would appear that there are a lot of folks out there who have experienced issues with the download.

1 Like

I update Windows 11 and MS Store every day, additionally, knowing there was an update to come I checked both before starting the process, yet I still had a problem.

The very definition of a quality system is that processes are repeatable - this process is different every time it is used. NOT a quality system therefore :roll_eyes:

1 Like

I have this issue too. After shutting down my PC, I need to do this repair download every time.
It’s a shame Asobo/MS has not addressed this issue as many customers are complaining about it.

1 Like

Same problem, no solution with powershell SHAME ON YOU

What? If you don’t know how to be pro admin … :wink:

Everything was working fine with MSFS until the release of Gaming Services 10.75.13001.0 a few days ago. I tried all of the mentioned remedies and nothing works. The only way I can get MSFS to start is by removing Gaming services with the Powershell command provided in this thread, then restoring Gaming Services 9.74.15001.0 from my system backup.

Maybe this has something to do with Gaming Services not being tested with SU 12 beta. Anyone else having this problem?

Hello AdvancedGrain30,

Same for me, none of the solutions provided by the community works.

Thanks for the information about the recent update of Gaming services (didn’t know that).

I’m glad you find a solution.

On my side, unfortunately, I’m stuck with Gaming Services 10.75.13001.0