Garmin G530 / G430 Cannot Activate Leg

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

I am not in developer mode.

Brief description of the issue:

I loaded a landing procedure in the stock Cessna 172 SP using G430 while in the middle of a flight. I then tried to activate a certain leg and the option in MENU was disabled. I also tried to activate it in G530 with the same result. I’ve also tried to create a flight plan in G530 and activate certain legs, but that feature doesn’t seem to work.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

In either device click FLT button to see a list of waypoints. Click the inner knob of the right-most dial to activate cursor. Use outer knob to scroll to a waypoint. Click MENU button to see a list of options. The option to “Activate leg” is disabled.

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Are you using the PMS50 mod and have you downloaded the latest version to be comparable with SU9?

1 Like

I am not using any mods. It’s only what came with the game. Should I use this mod?

If you are on PC and using an aircraft with the 530/430 then yes, get this mod.

Loads better and far more real world features.

1 Like

Yes, the basic G530 has issues.
The mod is better and on Discord the mod developer said that WT is planning to improve it on a later stage.

The topic has been closed, as the author has indicated a solution.