Garmin performance in aircraft after 1.9.5 patch - Solved

This is resolved. See my post below.

Sorry I don’t quite understand. Are you saying the glass cockpit gauges are stuttery/low frame rate? Have you not tried putting the glass cockpit refresh rate setting to medium/high?

Go to the graphics option and down to the very last option - GLASS COCKPIT REFRESH RATE.

That’s something that was added in 1.8.3. It defaults to medium. Asobo added it to try to gain a few fps for people with slower machines. I hate it at medium because it does just as you describe. I have it set to high and glass cockpit is silky smooth as it should be.

I said in my original message I didn’t want to do that. The gauges would run like FS9. When FS2020 was originally released the gauges/sim performance was smooth.

You dont wont to turn up the graphic setting to completely solve your issue and bring it back to what it was? Er…I dont understand.


They changed it so that the default is MEDIUM, so if you want to go back to the way it was before, you’ll NEED to go and change it.

Don’t understand either what you mean…just go and set the refresh rate on high

No, just an observation. Originally didn’t have to lower gauge refresh rate which the option was introduced in the second patch I believe. If your not seeing an issue on your end maybe it’s just me.

Because it’s Javascript, the Garmin refresh framerate has noticeable effect on the CPU usage and overall FPS, so Asobo introduced this setting so you can adjust it to your liking. Before that, one had to manually patch the Javascript code itself.
If you want to go back to 60 FPS for the Garmin, do it, but then don’t complain if your overall framerate drops by 10 or 15 FPS.

For the record, from what I’ve read, real electronic flight instruments framerate is only required to reach 20 FPS.

1 Like

I think what the user is trying to say is that the MEDIUM setting is way less than what is needed for a smooth display. I kind of agree with him.

I agree too. Something was altered. In fact, for me the high setting is not enough either! I use a Realsim G1000 and it’s noticeably slower than it was on earlier releases. Also, I use it in on a networked PC using WideView, so can afford any FPS loss it will cost.

well now you know, you can raise it up back to high which was what is was originally when it was released. Problem solved. Some of you guys jsut love to create extra problems for yourselves.
Here we are helping you with an issue and you’re rejecting it because its not default or whatever crazy reasoning you have

1 Like

I just want to report this was on my end. I had ‘Terrain Level Detail’ turned up trying to troubleshoot the LOD distance issue before a fix was posted in these forums. I forgot to turn it back down to 100. It’s back to normal. I’m using the highest gauge refresh settings getting good performance. Hopefully this helps someone who may see a problem and check their settings.