Getting no satellite data anywhere

I never had this problem before, just noticed 1 hour ago when I was going to fly. Had a flight yesterday at night without a problem.

Getting the same problem also. Seems to have started out of the blue. I’m suspecting this is on their end… although it’s odd because it only affects a few users, not everyone.

I tried all the potential fixes I could find (relogging, clearing/recreating cache, install xbox app, etc), nothing has made any difference. Doesn’t seem like this is a local issue tbh.

looks like they are in no hurry to fix it aswell

How do you know it only affects a few users and not all?

Just started to have this problem. Photogammetry, and bing graphics all turned on.
Also, 40GB of roll cache.
250Mbps internet connection and all at ultra. So, the problem is at Asobo/Microsoft’s end.

1 Like

Same here, stuck with generic farms bang in the middle of cities.

Same here. It just happened today. I tried deleting cache, turning online services off and on and photogrammetry as well, logging off and on but nothing worked. I hope Microsoft solves this issue soon. It’s a worldwide issue.

I find it extremely unprofessional of Asobo and MS to be completely ignoring their customers during this issue. They have not said a word or acknowledged the issue. They are an absolutely basket case of a company. Take peoples money and then deliver garbage. I understand that ■■■■ happens, things go wrong but bloody well own up to it and a the very least make a statement and let people know you are looking into it. People have been posting about this issue for a couple of weeks now. Not good enough.


Agree, they should at least acknowledge this, I downloaded and reinstalled 4 times over the last week thinking it was at my end. I imagine I’m not the only one who did this. Maybe the servers can’t cope since the Xbox users started


I reinstalled too as when the issue started, I was also getting CTD with any addon airport. This confused me and then realised that if I had Bing Maps setting enabled, it would crash any community addon. After turning off Bing Maps then I can use my addon sceneries albeit the surrounding Bing map data isn’t working due to this issue. So I reinstalled not quite understanding what was going on, I thought maybe I had a corrupted file. Would’ve been nice for MS to acknowledge it and tell users to not waste their time reinstalling.


I’ve got the same issue here at the moment only since today - Steam version. Basic ground sceneries everywhere and no airports being displayed in the menu.

1 Like

Having this problem too. I just want to play the game without it being a headache of dealing with bugs every few weeks :tired_face:


I have the same problem after reinstalling on a brand new SSD. tried everything from bing data settings to log on and uninstalling xbox app in windows. same thing everywhere.

If I fly in Tokyo it’s all made of autogen and NO photogrametry, terrible textures in the world map as others have said also. If I fly in my home area where there is no photogrametry, there is even worse scenery now than before when it was working, farms in city etc.

1 Like

I also have this. Even reinstalled the entire sim but didn’t help. Really annoyed with all the bugs and ■■■■ with msfs since launch. They need to step up their game and fix all these issues. Screw the fighterjets and drones and whatnot. FIX THE CORE FEATURES OF THE SIM.


Same issue here! Is there a problem with the servers?

1 Like

Same here. Steam version. Just encountered the issue today.
I tried all of the suggested work around:

  • sign in/out of Xbox account
  • turned on/off and cleared rolling cache
  • uninstall/installed xbox app
  • flushed DNS
  • rebooted my router
  • sacrificed a goat

Nothing. Not sure if Asobo has any control of the Bing map server but surely Microsoft does. They should be able to sort things out.


Poor goat 🥲

Have you aaaaaaall opened a ticket? I guess that’ll be the only way.
Sent mine on Friday, still no answer.

I just opened a ticket for support…