Getting simple animations working (Blender/Blender2MSFS)

Hi,
I’m getting stumped with this. I have one working and another that won’t work. I can’t figure out what I’m missing.
I create my blender object and it’s animation, pushing it down to the NLA editor. The animation works fine in Blender. The name of the animation is the same as it’s object. I add the tag to the objects XML file and place it in the scene with new guid etc.
The console shows the object loading without error. I’ve tried renaming the animation in the XML file which results in an error message in the console, so I’m assuming when named correctly MSFS is finding it.

<?xml version="1.0" ?>
<ModelInfo guid="{e4bcc7ec-d55a-4689-aaa3-a5b7ae0a8dee}" version="1.1">
	<Animation name="RightChannelBouy" guid="d71558eb-fc0f-4226-9fac-da35614a57e0" type="Standard" typeParams="AutoPlay"/>
</ModelInfo>

I’ve tried packaging and adding to the community folder, deleting that and running from the project, restarting the flight, and restarting MSFS, deleting and repackaging the project. I thought I’d figured this out last night when the animation on the other object was working, but it seems not.

Any thoughts?
Thanks in advance.
Andy

Did you ever figure it out. I know in my track below…mine says "the name and Action.001 attached but the name in the NLA upper right is just “the name” any way to edit the track name below…Make sense?

BobM.