GlassCopckpit screens in Longitude not working - all screens 'unlinked'

on PC - all latest updates.
Citation Longitude Glass Cockpit screens appear white, no graphics on it.
C4J screens appear to work

I am not new on the game - 400 h , about 50h on Longitude

how to fix it? Thanks

Gforce 2080 Nvidia, 3090X Ryzen, 64 MB

Do you have any mods installed? Try disabling those.

If you have the PMS50 GTN750 file, delete that and try to reproduce.

Do you have the same issue by following the OP’s repro steps?

Provide extra information to complete the original description of the issue:

If relevant, provide additonal screenshots/video:

Have you installed the WT G3000 mod?
Or did you install LONGITUDE mod?
If so, try uninstalling the mod and running it to see what is causing the problem.
Currently, the WT G3000 is known to have performance problems.
It says an update is needed.
(Some opinions, not sure)

Edit.
After a bit of research, it is said that the WT G3000 works normally. There seems to be a problem with the aircraft using the WT G3000. For example, TBM930 mode and LONGITUDE mode are both said to not work. An update is required. Both have updated versions. It is not listed on the official route, Flightsim.to. I’ll leave a link if you need it.

Thanks a lot!
somehow it is the mods - even if I moved them away from the directory …
do you have the link for the G3000 mod new version?
the Flight dynamics seems to be on flightsim.to
Again - thanks !!!

Hi, I’m Jon and I’m an idiot! :laughing:

I had ANOTHER mod from flightsim.to on there, the flight dynamics mod. Removed that and the screens are working. I’ll try reinstalling the WT mod.

Hi there,

When using the bug template, this is not the correct way to fill it out:

You are supposed to put information in the fields like this:

image

I will be moving this to the Community Support category, as it appears that the issue is related to mods and not the base sim. The Bug Reports category is only for bugs with the base sim. We always ask that you remove all mods and test before reporting a bug. Thank you!

2 Likes

Hi there,
Welcome to the forums!

If you have additional information to provide, you can use this template to give that information. Like this:


Do you have the same issue by following the OP’s repro steps?

Yes

Provide extra information to complete the original description of the issue:

Some extra information

If relevant, provide additonal screenshots/video:

1 Like

Thanks a lot!

wait… did that fix your issue? If so, heck yes!

Thanks, resolved.
Issue was the Asobo dynamics (removed) and G3000 needed removal, but worked after restore

What do you mean by “worked after restore”? Are you simply running without the two mods or did you put them back in (restore) and they worked?

yes - i started without mods. the flight displays were back, and the Garmin screens, and the mid console ‘backup’ instrument. (all were whaite with the mods, and could not be accessed by mouse to duplicate them).
then I restored the G3000 mod. not the Asobo dynamics mod.
And it worked, the ‘original plane’ Garmin layout poped up.
When tried by removing only the Asobo mod it did not work …
I don’t understand why, but I did not dig into details how mods are called in the software.
I am not sure - it looks to me the ‘size’ of the cockpit view has changed slightly, but no significant differences.
some plane instruments have improved functionality in the new ‘FS version’ of the Longitude.