Glide slope on ILS is not working

Well I seem to be following your directions, but it frequently fails for me. I’ve never been able to tell what I’m doing wrong or different between times it works and times it fails. Failures occur across different aircraft, across different airports/approaches. ILS might be more reliable, but sometimes fails. RNAV seems less reliable, but sometimes works.

I use NAV mode to follow the flight plan, then switch to APPR a few miles before the FAF. If it doesn’t capture glide scope, I try hitting APPR off and on a few times as soon as I can to try to get it to pitch down, but it never works once it has failed the first time.

Manually descending and recapturing has never worked for me. Only manually doing the landing works.

This can happen as well. If it’s ‘stuck’ in APR, I have to momentarily switch to e.g. HDG and V/S to ‘reset’ the intercept logic and then try APR, or NAV/LOC and then APR again.

It’s a real pain and I hope Asobo fixes these problems.
At least one AP/FD bug has been fixed with the latest patch.

2 Likes

Ooh, that can’t hurt to try. :smiley: Next time it happens I’ll try a more thorough mode reset, and log whether that helped or not.

Thanks for the hints, and the confirmation that I’m at least mostly doing something right. :wink:

1 Like

Time permitting you could even try a ‘full’ reset, cycling the AP and FD off as well.

I figured out my issue. I was forgetting to change Nav Source to Nav1 when on Final. Duh.

1 Like

Im having the same issue with both asobo and a320nx. Anyone else with glideslope intercept problems?

Edited on 2/2/2022:
Solved.
Problem was with me. Flying too fast and too high.
Fly between 160 and 200 IAS.
Fly below GS diamond.

I have this problem on a WT CJ4.

Same flight.
Sometimes the white “GS” remains on (bottom right of scoreboard)
as I fly over the airport.
Sometimes it will change to green (moves up to the top) and follows the glide slope.

After many flights, I cannot determine the reason.

No issue from me using the FBW. I manually enter the ILS frequency into the MCDU NAV RAD page. Turn on LS to bring the glideslope indicator. Press APP button to arm them and press both AP1 and AP2.

Also make sure you have all assists turn off. They interfere with the ILS.

Having this issue at JFK and I’m at the correct altitude. It’s like the diamond is saying I need to be lower when I’m at the right altitude and baro

There are several things that happen to capture an ILS glideslope. It is important to have and understand the approach plate. It has the ILS frequency, waypoints, and altitudes needed. The approach should start at one of the transition waypoints (IAF - Initial Approach Fix) at the correct altitude. Next is the IF or Initial Fix to acquire the localizer and configure for landing. Next is the Final Approach Fix where the FAF altitude should intercept the ILS glideslope. The ILS approach is generic (except for CAT II/III) and does not need an autopilot. If a glideslope is not working, it should be verified by hand-flying the approach.

If the autopilot does not capture the glideslope correctly, then it is an autopilot problem, not an ILS problem. In addition, for aircraft without AutoThrottle, the aircraft can fly out of the glideslope if the throttle is managed incorrectly especially if gear or flaps are extended at the wrong time.

Landings in general and instrument landings in particular are very difficult to master and need constant practice.

i have this problem only with the longitude. i have everything correct and i hear it pickup the localizer but the plane does not descend. i have to go land manually, very problematic for me at times, LOL. i use the mod title for the g3000-5000. today i flew a short flight and it worked. i frankly don’t get it!!!

I too have been struggling since the last update, the axes of the runways in mode (ILS) of the Tunis Carthage airport are no longer correct. runway 01 is 010° now it is 020° the plane landed on the left side of the runway, the same for the other runways, Pls is there a solution?

I subscribed to Navigraph to get these navdata fixed because of this issue.

Same here. In c172 and tbm930. Auto pilot intercepts glideslope from below, starts tracking down but then plane levels out as glide sloe indicator keeps moving down