Glitchy Pixels at top of screen

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Bug occurs both with empty community folder and addons loaded

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Top center of screen shows large glitching pixels in checkered flag pattern under drop down menu bar from both VC and external views. Becomes particularly apparent whilst panning view left/right/up/down.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Flying RNAV approach into NZAA in default Baron.
Flying JF Arrow NZNS - NZMK

PC specs for those who want to assist (if not entered in your profile)
See profile

Build Version # when you first started experiencing this issue:

Are you on the Steam or Microsoft Store version?

`Did you submit this to Zendesk? If so, what is your ticket #?’
Not yet

Check your video card temps. Do you see those artifacts when you first start or do they grow in?

If your video card temps are high, how’s room temp, dust in heat sinks and fans, etc?

I’ve seen those kinds of things when video cards overheat. Can’t say for sure that’s what it is but sure looks familiar.

What GPU? What are your temps like?.(especially Vram)

What is your render scale set at? If it’s over 100 move it back to 100 and it should stop the artifacting


Same issue here as well with my 3090. Pixels appear at the top half of the screen, but only when moving. Issue starts occurring randomly through the flight. Sometimes after a few minutes, or an hour. The only way to fix it is close the sim and reopen. This issue didn’t occur at all before Sim Update 5. I see one user referencing render scaling. I have mine at 110, I’ll try to bring it back down to 100 to see if it fixes.

This doesn’t look like typical GPU artifacting. For reference, I have a 3090. The 3000 series won’t exhibit memory artifacting due to error-correcting memory modules. As you can see in the screenshot I’ve attached, my GPU temp is 64C and VRAM modules are at 84C, well within the specs for GDDR6X.


For me its happening every time I pan in exterior camera view.

GPU is NVIDIA GeForce RTX 2070 SUPER (4GB) and temperature is in the steady mid to high 60 degrees range throughout the flight with no spikes noted.

Render scale is set to 130, which is what it was before SU5.

Any more ideas to help trouble shoot are greatly appreciated!

1 Like

it happens more w/ taa/oversampling. but in certain locations i can find it with no AA and undersampling to 90.

before SU5 taa & oversampling worked and the game looked good and ran fine. if i have any fps it’s from fighting these new artifacts. gpu is 58C only 50% usage.

edit: i reported this on day 1 of su5 and got no response


Good to know, thanks. Do you also have a Nvidia GPU? If it seems to be limited to Nvidia, it’s possible this could be a driver-level issue as well.

I have observed the same issue…before SU5 my render scaling was set to 130…no issues, ran great. Now I get the same blocking pixels on the top menu unless I reduce the render scaling to 100…which solves the problems…but gives me lower quality resolution.

I have Nvidia latest drivers.

Exactly same issue. After PC/Game restart the problem is gone for few mintues and coming back (from 5 mintues to 1hrs) i thought its temps but the issue apperead in windowed mode 600x800 too. All updates/drivers latest.

It is weird because i didnt have this issue in the morning lol

Folks, be sure to post your graphics card if you have this issue. That way we can isolate if it’s Nvidia or AMD. Seems so far, the issue is limited to Nvidia.

1 Like

I can confirm I solved this issue by rolling back my driver to 466.77 (for RTX3070). Of course this is not a long term solution and the bug needs to be fixed by Asobo.

1 Like

Thanks @MetalPlains3097, will give this a try next day I’m at home and report back!

1 Like

no problem, completely fixed it for me, I had it on every flight, tried reducing render scaling (was running at 130) still got it, reducing LOD’s which I’d upped to 5 and 9 in cfg, still got it, getting rid of TAA helped a lot, became much rarer, but I hated the look so was still pleased when I got it once haha. But since rolling back drivers not had a single issue with it, so fingers crossed for you!

Happens for me too with a 3090. VRAM temps in the 90s at times but apparently that’s within limits! Will try rolling back the driver later.

really? its a driver bug and needs to be fixed by nvidia.

I’d also recommend everyone with this issue to report this to Nvidia. The sooner they’re made aware of a potential driver issue, the quicker it’ll get fixed.


Same issue here. Nvidia 3080 with latest driver. Temps ok, problem occurs since SU5.

Is this actually a fact? Just one person reported that rollback might help.

FYI. I’ve just come over from this thread: Screen tearing, lagging between views
Running a Gigabyte RTX 2060S Windforce Super Gaming OC 8G (3 fans IIRC) with 471.11 drivers and I was seeing that tearing/blocky artifacting yesterday when running > 100% Render Scaling