Glitchy Pixels at top of screen

I just got these pixels again. I used render scale at 120. Switching back to 100 solved it.
I tried various render scales, 115, 110… everyone had the glitchy pixels instantly. Whenever I got back to 100 the glitch was gone.

So it seems it’s somehow bound to render scale.

Render scale made no difference to me, though it seemed to occur more frequently and earlier on in the flight with higher ender scaling.

Rolling back the driver was the only thing that solved it, been a good few days with lots of flying and hasn’t happened at all since, and been back to 150% render scale.

1 Like

Rolling back to driver 466.77 seems to have fixed this issue for me. I’ve played for several hours in various aircraft and locations without the artifact pixels appearing. Thanks very much @MetalPlains3097!

(I also did not have to adjust my render scale below my preferred value of 130 to fix)


Glad it’s sorted for you.
FWIW I’ve yet to be able to recreate the artifacting I saw. Same graphical settings; 150% Render Scale; now on 471.41 driver. Been flying for a couple of hours and GPU has been sat at 99-100% with fan speeds around 2000rpm and temp about 71C. Wiggling my mouse like crazy (in and outside of plane) and can’t see any glitching. Oddly dissapointed I cannot recreate it - if I hadn’t taken screenshots then I’d be doubting myself!

1 Like

Same here, 1080ti. My GPU is perfectly fine, no issues with temps or previous version. Latest drivers.

1 Like

Great it’s sorted for you

I think I will wait to update till the next drivers come out, it’s an easy process but I can’t face seeing the artifacts again and then having to reinstall the old drivers!

1 Like

I had this issue (RTX 3080 with latest drivers) after SU5, but only when render scale was above 100. At 100 it went away. Bizarrely, and I know this is of no help to anyone, the problem appears to have gone away (running render scale at 120 now). I did not roll back drivers. Very weird.


You’re the second person to report it go away by itself- which makes me wonder if my driver roll back was a placebo fix. I wonder if it was possibly related to high server load around the update?

1 Like

I have the same pixels after SU5.
render scale 100
1920 x1080 screen.

Same issue for me too. I also have a 3090, and this only came up after SU5. I thought it might be something from my community folder, but even after I emptied it, I still got this bug. I will try rolling back my driver as well. Thanks, fellas!

1 Like

rolling it back helped me as well but even if rolling the driver back fixes the problem, it doesn’t prove the driver is at fault. correlation is not causation.

1 Like

I’m on that driver and repeatedly ran into the issue, usually happening maybe 30-60min into the flight…
Will try to roll back.

GPU data (RTX 2080 OC 8GB): 95% usage, 75°C, nothing out of the ordinary.
I’ve undervolted it for less power usage, but it’s absolutely stable and has been before SU5, so I doubt this is related.

Odd, I’m still on 471.41 and have experience not a single problem since - Render Scale around 135% for the most time - most peculiar.

I’m on ultra as well, render scaling 125% at 1440p screen resolution.

My guess is that something in the engine suddenly goes wrong and ends up in a weird state.
Apart from the artifacts at the top line, you get flickers when changing the views (ext/int).

Hard to guess what the source might be, it doesn’t happen for me on every flight, just had it twice since SU5.

1 Like

Whilst I have happily got rid of the artificact pixels at the top of screen, I have began noticing a more subtle pixel glitch around the aircraft when in drone camera and panning at fast speed.

In the above screenshot you can see it above and below the right hand wing. Has this been reported anywhere else?

How did you get rid of it, exactly?

Rolled back my driver to version 466.77, but others above have reported the issue fixing itself without intervention.

This has been the case since first release, most pronounced in overcast situations.

And they’re back -

and in cockpit too

All was good earlier - enjoying a long-haul, low altitude, VFR over Indonesia - I was reading this thread this morning and thought I’d check (with some heavy mouse wiggling).
I’d been in-game/flight for around 4hrs - paused a few times to enjoy a brief bit of sunshine, eat, etc., but kept game sat running. MSFS is limited to 40FPS but drops when panning around; hovering around 40% CPU/80% GPU Utilization (it goes up if I pan, etc.). Went to look around at the scenery a few minutes ago and I noticed that the artifacts were back. First, and only, time since August 2nd.
Restarted PC down, reloaded the exact same location and it’s gone - bizarre.
Both LODs at 4 and running Ultra and 120% Render Scale (so I can read the dials) and I’m still running the 471.41 drivers that have been fine for the last 5-6 days.

Nice to hear. I just did an hour and half flight yesterday with render scaling back up to 110%, and no issue. Never had a chance to try rolling back the driver, either. I’m not suggesting it’s “fixed” itself, but perhaps the issue is a bit more random than realized. For example, only happens in certain situations.