GNS530 mod

Hey everybody,

sorry to say this but your mod is not enjoyable for me. I have only tried this with the PA44!
There are serval bugs that occur. I will name all of which I experienced and if you need any more information, just tell me.

  1. Avionic freeze as mentioned here before, OBS and CDI button still working. Being on vatsim the com switch button does work and it changes the frequencies but it wont display the change and any change with the knob to select a different freq.
  2. FLP does not behave normal. When putting in a SID it wont be displayed in the FLP page. Putting in my route leeds to a bug where it cant find new waypoints. And in addition the FLP page wont show the blinking selection, so I dont know where my selection is in that moment but I can edit the waypoint which is selected without me knowing which one.
  3. Using the AP in GPS or VLOC mode gives me slow turning rates which results in bad accuarcy.

I will try everthing later in a default plane, but since the PA44 uses the default GNS530 I am not certain this will fix my issues.

But thanks for the great work!

Hello
The Mod should work fine with the carenado aircrafts.

Maybe a wrong installation?

Please read the installation and bug reporting information at the top of this thread.

Especially, if you have an issue and want my help, please be very precise.

3 Likes

As you say, a small difference – no big concern.

It also could depend on how Asobo calculate these ranges.

DME should certainly approximate to “Slant Range” – at least when more than a mile or so from the DME – but is it.

GPS could be calculated as either . Ground range or Slant Range…

Makes very little difference, especially at low altitudes, but maybe one day, I may try to test and see what Asobo are really providing.

Anyone know how the mod is looking with the update?

Just tried few things and everything seems to work.
Now I need to test more.

I assume ASOBO did not fix the Insert WP in their code ?

No mention of it in the latest update notes

In fact, only one specific “Change Log” GNS530 Update by Asobo, since release :frowning:

2 Likes

Flying it right now, confirmed seems to be ok so far.

1 Like

Waypoint insertion is still buggy with the original GNS530, in a different way but buggy.
U-turn bug is still here.

1 Like

I just flew it for an hour in the Cessna, didn’t have any issues. But, I didn’t do much more than a couple of in-the-cockpit direct-to’s (direct to 69NH, then direct to back to KASH). Original flight plan was just KASH to KASH to a parking spot. Checked out the first 3 map pages plus the waypoint and another page, used the autopilot (NAV) back to KASH. It flew it nicely.

Interesting that when I started cold and dark, the both the 530 and 430 were off. At first I thought it was because I was using a livery for the plane with the panel.cfg hack, but, nope, just had to turn them on with the knob, just like the KX155’s in the 152. Pretty cool :slight_smile:
That and the Transponder had to be turned on. The autopilot I think had no way to turn off, and the ADF didn’t turn off, either.

For me, everything seems to work now.
I will release 1.0.22 tomorrow.

For information, I have added an option in the default NAV page to restart the GPS unit (in case you have trouble other than a CTD or a complete freeze). This reloads also your original flight plan. Maybe useful sometimes.

5 Likes

Hei again,

so my post was unnecessary. There is a bug where my avionics freeze after some flight time, but it also occurs with the default avionic.
In the end its the PA44 thats buggy and not your mod (should have tested that before writting, but it was a busy day).
Anyways I am glad to enjoy your mod now!

Thanks for your feedback.
I’m currently using the carenado m20R. No problem with it.

1 Like

Since you fly the PA44 as well, I wanted to ask someone; are you also unable to get the HSI CDI to connect to the GNS530’s active flightplan?

Even when I set the CDI selection in the GNS to GPS instead of VLOC, the HSI still seems to be indicating NAV1 input.

The map cursor add-on is awesome! Very handy. So far, GNS530 mod works perfectly after the update. Thank you very much!

2 Likes

Another user seems to having the same issue:

“3. HSI still doesn’t sync with GPS when CDI set to GPS (even thought HSI featured in PA44 does has GPS marking inside HSI gauge)”
https://www.avsim.com/forums/topic/589813-carenado-pa44-mini-review/?do=findComment&comment=4428917

I think I’m having this issue too. Will check again. We might need to contact Carenado and file a bug report through their zendesk. https://carenado.zendesk.com/hc/en-us

Fixed in latest version of MSFS 1.12.13.0 (12/22/2020)
Something you will see when in the GNS530 (Modded or not)

  • The slow roll out back out of bank, and onto course is now FIXED ,
  • It now rolls out of bank at same rate it rolls into bank …

BEFORE UPDATE

AFTER UPDATE

Note: Green - Bank Angle * 5 degrees

Now the Green (same color in both plots) Rolls back out of bank at the same rate it went into the bank, unlike before, where it just cautiously inched out at a very slow rate.

This should make any turns the plane makes on the GPS map, appear to follow the desired course a lot better,

To get really “TECHNICAL” it’s a little more “Wiggly” but at least its not “Twitchie:wink:

3 Likes

Where is the link for the GNS mod?

1st post in this topic (3rd line) use that link

1 Like

NEW VERSION 1.0.22

Available at: https://pms50.com/fs2020/gns530/pms50-gns530.zip

Changelog

  • Added real-time METAR data (see note in readme file)
  • Added a menu item in the default NAV page for restarting the GPS.
  • VOR/LOC standby frequency automatically set to ILS/VOR frequency when loading or activating approach
  • Added messages about airspaces (4 types of messages as described in the GNS530 documentation)
  • Added messages for missing departure and/or arrival airports
  • Last selected waypoint in the map available for the waypoint page
  • Changing some distance display in nearest pages (rounded)
  • Bugfix: selection mode blocked after activating an approach from the procedure menu
  • Bugfix: incorrect database information may freeze the GPS when displaying a procedure map
17 Likes

This may affect the reactivation of an approach after a direct To an approach waypoint in the MOD.
I will make the necessary fix for that (checking reactivation at 2nm of the target instead of 1nm now).