GNS530 mod

I don’t have any other mod for the GNS nor the C172. However, I do have Working Title mods installed, Salty 747 and FBW A320.
As for hardware, I only use rudder pedals + saitek yoke.

Ok could you try without any other MOD installed?

Most likely cause of this is something overriding your plane’s Panel.cfg, or a corruption.

Easiest way to fix it is to:-

  • Delete the C172 Classic aircraft via the CONTENT MANAGER (do not manually delete files in Official !!)
  • Shut down MSFS
  • Temporarily remove all content in COMMUNITY ( copy it and save it somewhere OUTSIDE of the MSFS folder structure)
  • Re-Start MSFS
  • Re-download and install the C172 Classic via Content Manager
  • Test it and make sure radios now act independently.

Then you can start adding back other content into Community (while MSFS is not running !!)

You may not be using a GPS mod that affects the 530 mod, but you are using a Livery for the C172 Classic. It’s because the Livery does not have the appropriate panel.xml file it needs. You can get the panel.xml file from the MSFS Aviator’s livery. Don’t forget to add the file to the livery’s layout.json.

3 Likes

Excellent point !!! (Of course !! )

1 Like

Look like the UK Update (2/16/2021) has done nothing to affect the GNS530 Mod ?

Still appears (to me) to run as before.

Looking at the Asobo “Brief” Update notes, it does not like anything done in the update “should” affect the GNS530 or the GNS530 Mod, good or bad.

Maybe “Sim Update 3” ( sometime March 2021 ?), will address some of the issues still restricting some functionality of the GNS530.


Sometimes it is difficult to get a “Big Picture” of all these MSFS Updates, because each one is posted in a different thread.

To help myself keep track (any anyone else interested), I have made an “Unofficial” Thread listing all the MSFS Updates that occur each year.

If nothing else, it makes searching for a particular update item, far easier, as they are all, in one Post.

1 Like

The main changes will probably occur with the sim update 3 in march.

2 Likes

I used it for a few flights yesterday in the 172, and it worked flawlessly.

1 Like

Anyone with the C172 Steam Gauge version, GNS530 Mod and “YourControls” interested in testing the GNS530 Mod with “YourControls”

(USA Eastern time, evenings or weekend) Discord Voice Coms really a must for this.

Getting a CTD on loading up.
Seems to be a conflict between the 530 mod and navigraph - remove one or the other, and it’s fine, but both together causes a CTD.
So far only tested with the Carenado Seminole and Asobo C172, as I’ve run out of time to test with others today.

Latest version of the mod (downloaded from github earlier today).

Both were working for me the last few days.

GNS530 V 1.0.27
Navigraph AIRAC Cycle 2101 rev.2

I’ve flown the steam 172 a lot with both of those, and the Seminole was spawned just to test something for another user, but it did not CTD all the same.

You are sure you did download the correct version? I once downloaded accidentally the source code. So maybe check that… For me I have no problems at all with the latest version and the C172 and Mooney. Seminole I do not have.

Yeah, got the .zip off GitHub. Works fine without the navigraph folder in community. With it, it gets as far as the Garmin splash screen then ctd. Will try the Mooney when I get back from work but I suspect the same outcome

Are you sure you have downloaded the release and not the source code?
You have a link in the documentation where you are sure to get the proper version (not the github one).

Almost certain. Will check when I get home

It’s this link I’ve got
https://pms50.com/fs2020/gns530/pms50-gns530.zip

Under latest release on the gh

This is the correct link.
Could you give more information in order to reproduce the issue: airport, initial flight plan, etc…
Do you have some other Mods installed?

Just learning about this - very excited to try it out in the Mooney, thank you!

1 Like

I’ve tried to recreate again, and now I can’t. Navigraph updated to a newer version of the AIRAC data (rev.3 vs rev.1), but otherwise no changes.

Don’t know if it was a glitch in the previous Navigraph data, or maybe a symlink went wonky (I backed up the Community folder and emptied it for the world update), but I’ve done three or four long flights, both from C&D and spawned on the runway, in various planes, and it won’t crash on me. Strange, but better than the alternative.

1 Like

NEXT version of LNM will create .pln file that have the required airport assocaited with fixes (if applicable), so they will then load correctly in MSFS ( ie load correctly in GNS530 Mod)

Just tested a Pre-Release – works great …

fpl2.pln (9.6 KB) generated for MSFS by Pre-Release.

MSFS 2020 Flight plane exported from LNM (pre release, next update), with correct airport associated with fixes – Loads correctly now into GNS530 Mod !!

This flight plan includes both fixes associated with airports, as well as fixes that are not associated with airport.

Both type now are generated correctly for MSFS by LNM :slight_smile: (thanks albar965 )

4 Likes