Going out of my mind with new Bravo Quadrant! Help please!

Got it today and am already beginning to regret it. In MSFS it’s only applying throttle from 0-100% when I push up to 50% throttle. Anything below 50% is going into reverse thrust. What gives??? In X-Plane it won’t retain my profile settings. This thing is making me crazy.

I’ve installed the drivers for both MSFS and X-Plane. For the most part everything else is working fine in MSFS. I undid the avionics and light bindings for the switches, all I need to know is why I can go from zero throttle to full starting at zero and why below 50% it is applying reverse thrust.

Try calibrating it in Windows.

Also there is a detent in all the levers. Bringing the handle below that detent pressses a button that for throttle is linked to reverse thrust, for props for feathering, and cutoff I think for mixture.

A very good youtube video. I used it to help setup my Bravo. The fisrst for various aircraft and the second for autopilot

Here is one for setting up the auto pilot

I know, that’s not what I’m reporting. Another person on here reported this too but never posted if he found a solution. If I have the throttle at idle (at the detent, not below) I get no thrust until I reach halfway up the full range. Then if I lower the throttle below 50% travel it kicks in reverse thrust. I don’t have this problem in X-Plane and the MSFS controls configuration section shows full range of axis from 0-100. It happens with all planes, obviously a Cessna 172 doesn’t have reverse thrust so it’s not giving me reverse thrust with the 172 but there’s no engine power until I throttle up past 50%:

*Edit - tried creating new profiles and same thing. With the 172 the mixture works perfectly going from 0-100% and it reflects on the screen as I move the lever. Same goes for the props levers. With throttle it doesn’t start applying power until 50% forward in travel. Again, in the controls section it shows a full 0-100% range of motion. Not sure what the heck is going on.

1 Like

Finally figured it out. I had to delete the assigned setting for throttle and just remap it. It’s the exact same mapping as before (Joystick L-Axis Y). No idea why but removing it and redoing it fixed it.

I haven’t heard too many people complain about that but you know what, my mixture only works about 50% on my single engine profile. I’m going to try and just delete the map for it and relink it. I know there’s no hardware issue as that lever works fine on a 4 engine plane. But glad you figured out your issue.

I also manually selected the button rather than used the auto-sense. Another thing I found it might have been was on one profile it was set to Throttle 1 Axis 0-100% instead of using just Throttle 1 Axis (without the percentage next to it). Anyhoo, I’m all set with all my profiles now. Now to get to bed!

I had the same issue and it was driving me mad!

The fix ended up being the last thing you mentioned - I had to select ‘Throttle 1 Axis’ instead of ‘Throttle 1 Axis 0-100%’.

So strange, but thanks for sharing what worked for you.

1 Like

I have similar problem, dual engine turboprop configuration:

  • Throttle 1 and 2 axis was not working. stuck at 50%
    - I tried to detect the input but the axis got to work in a linear -100% to 100% (as a result nothing happens until you pass the 50% of the leverage run)

    • to solve it had to select the Throttle 0-100% axis and assign the default Joystick L Axis Y (for engine 1) and L-X (for engine 2)
  • Propeller has the same problem and still did not find a solution as it seems doesn’t have another axis I can select

    • with the default axis command the lever movements do not command a movement in the game
    • if I detect the input is turning into -100% to 100% type of input that is not functional
    • does anybody knows if there is another propeller axis to select?
  • Mixture controls worked fine out of the box, no need to change anything

Any suggestions on how to fix the propeller controls?

I had to do the opposite, select 0-100% and assign the axis that were by default to the other throttle command

My propeller axis control works fine, just had to reverse axis if I recall. I’m not at home right now to check but have your tried deleting the mapping and applying with the setting blank then go back in and manually choose Propeller 1 Axis rather than using the autodetect and moving the lever? Sometimes you have to manually select, I had an issue where it wouldn’t work right using the autodetect for some odd reason, though that was for throttle. All my controls have been working since posting here.

Thank you for answering, much appreciate the help.
Yes I tried to unbind the mapping and reselect.
The autodetect is weird as selects either the + or the - input, depending in what direction you move the lever doing the autodetect. But manually selecting the correct input gives the warning that this axis input is not recommended.

my situation in summary:
Throttle: had to select the throttle 0-100% and manually assign the axis - reverse axis unchecked
Propeller: error when assigning the axis manually - autodetect gives the 50% bug (but the axis works)
Mixture: worked fine out of the box - reverse axis checked

I even tried to change USB port where the device is connected (with low expectations but never know)

What looks the strangest to me is that everybody is having a different experience.
Being these threads are relatively small, only very few people are having problems

DUPLICATE THE PROFILE - after you duplicate the profile and name it, Unassign all the axis command that don’t work in the duplicated profile, reassign them and everything falls in place.

But the key is DUPLICATE THE PROFILE. If you work on the original default (even with changed name) it goes nuts for reasons I ignore