Graphics Settings i9-10900K & RTX 3090

I had that issue as well with far lower specs than you (Ryzen 2700X + 2080). THat and melty looking buildings. I turned off my rolling cache and both problems are cleared right up. I turn it back on, that the problem is back.

If you have fast internet, I would recommend trying that to see if it helps

Oops, I forgot to mention that. My rolling cache is off. I have gigabit internet service.

Another thing to try.

Find your UserCfg.opt file and edit it in notepad. You’ll find it in the same folder where your flight plan files get saved by default. CHange the line that says:

LoDFactor 2.000000

to

LoDFactor 4.000000

1 Like

2 things to keep in mind if you edit the UserCfg.opt file manually

  1. You’ll have to restart your sim for changes to take effect
  2. if you make any changes to your graphics in game, it will overwrite your manual changes for LoDFactor, as 2.00000 is the max it will allow you to set from that menu.

You can also try setting both terrain and object to LoDFactor 4.000000. The one that should draw stuff in farther is the ObjectsLoD.

You may also want to look at this mod that will draw in trees much farther away. Just carefully read the instructions before installing it.

1 Like

Did you have any luck?

2 Likes

Take a look at the topic below. Lod mod helps.

1 Like

Thank you for the suggestions. I won’t be able to give it a try until tomorrow though. I’ll let you know how I make out.

1 Like

OP is complaining about stuttering and you go and suggest this? Man ohh man… Wrong advice. This setting will cause stutters as it heavily loads the CPU, causing you to become main thread limited. To achieve smoothness in this sim, you MUST be GPU limited at all times. This way the CPU is able to provide the data to the GPU at a constant steady pace. Increase your GPU settings until you become GPU limited, ensuring that you are never main thread limited. It is a fine balance.

I have this mod to usercfg file and no sttuer.
i9 9900k RTX3090 4k Hyperthreading OFF

ULTRA settings.

1 Like

Better have a large rolling cache in a M.2 drive, smooth things a lot.

The UserCfg.opt mod did not present any noticeable difference for me. The Vegetation Draw Distance Fix however did show an improvement in the scenery popping while rendering. I used the 50-75 with default tree sizes and I’m very pleased with the results?

On another note, what’s up with the scenery spikes? I just saw in the “Bugs” section that it was “complete.” Doesn’t look like it…

Hi, you had a FPS improvement and lower the mainthread with this modification ? How much ?

I have also some weird glitchs at some places where it wasn’t before. Strange.

With a Ryzen 3700X, 32GB 3600.C16 and RTX 3080 FE, I set on Ultra and lower Terrain Details from 200 to 150 and supersampling texture on 4X4 (Not sure of the settings, translated from the ones I have, on my french interface). It’s the best compromise I found to see no difference between Ultra and these settings. I have a 35 Inches 3440*1440.

I run the game at max Ultra 3440x1440 with my 10900 + 2080 ti, I think you should be able to do the same in your resolution with 3090.

1 Like

I don’t know what my FPS are. I’ve never put that much thought into FPS with any flight simulator. If it appears smooth while I’m flying, with no stutters, I’m good with whatever that number may be.

Spikes are a bug from last patch that somehow went unnoticed in “testing”, despite the fact they’re pretty much everywhere.

You only have 2 options atm to deal with spikes:

  1. Deal with them until the patch in 2 weeks
  2. There’s a mod on flightsim.to that will fix all the spikes globally. However you’ll have to remember to get rid of it before the next update.

Sorry that the setting suggestions didn’t help with the draw-in. The object LoD at 4.000000 should have done it. Obviously it didn’t.

Don’t be sorry! You’ve been a huge help. Thank you.

I had terrible draw-in and bad photogrammetry issues until I disabled my rolling cache and made the changes I listed.

One question though. You said you had disabled your rolling cache, but did you actually delete it as well? Maybe it’s not related, but doesn’t hurt to try. I honestly have very little faith in their systems to actually not use stuff already in the cache even though it’s disabled, just not adding new stuff into it. Call me paranoid, but having been a software developer since the mid 90s, when I see constant shoddy work, I expect more shoddy work.

I’ll make sure it’s deleted.

10900 and 3090 at 4K? Just max it all out, keep render scale at 100, TURN OFF VSYNC, and call it good.

There’s a tree mod that looks pretty good, costs about 2-10fps depending on situation.

Don’t expect much beyond 50-60fps. CPU’s just can’t do it yet.

I have implemented the Vegetation Draw Distance Fix. Is that the tree mod you’re referring to? I have VSYNC on. Can you clarify why it should be off?