Gsync, microstutter less 1 second

hi all, I recently changed my monitor ( from a full hd 60hz freesync to a qwhd 165hz gsync ) and I notice that when I move the whole view to the left, for example, there are some microstutters, less than a second, which don’t make the beautiful fluid image) how can I fix it? do i need to change the nvidia settings for this monitor? the sim settings in the su10 were fine, i had the fps locked at 30 and the image was always fluid, now my question is if i have to do some adjustments in the nvidia panel, thanks to whoever will answer

check that gsync is also enabled in nvdia control center ( window- and fullscreen ).

I’ve tried… but nothing.

In Nvidia control panel under 3d settings Turn V-Sync to ON, and in game have V-Sync set to OFF.

Also i suggest running the sim exe in high priority (helped with my stuttering)

1 Like

have you still set a fps limit ? may the stutters have nothing to do with gsync…

PS: setting Vsync in-game , and not in nvidia control panel, is recommended. V-Sync works just if you go above your monitors fps, where I assume that it not happens in-flight :slight_smile: ( and also not play with priority settings, all of that is not necessary )

I understand it to be the opposite, On in NVCP and off in-game…that’s how I’ve always had it set

but that caused for many users lots of issues in MSFS ( don’t ask why :rofl: )

At least… I assume he can also disabled VSync and set a usefull FPS max in nvidia control panel in generall settings 5 fps below 165 and in MSFS settings may be to 40.

EDIT: that reddit post is an old mistake… it was in the first ages of gsync, that vsync must be off. But in a newer spec ( since years ) , vsync in still needed to avoid tearing above the frequencies the monitor can handle.

Interesting, i have all frame limiting and v-sync off…pure butter!
I’ll have to look back into the g-sync debate…pretty much i never use or need to use v-sync in any games with my settings…

yep… as mentioned… years ( ages ) ago… the first g-sync specs. Today is Vsync again responsible only for e.g. avoid tearing ( eg. if OP come in ranges above 160-…165fps ) and of course it can used like a “soft” fps limiter ( the low-power-mode of msfs use it ). With no fps limit ( max fps, or vsync ) you run into situations where games render 1000fps etc , and of course tearing, etc ). Many users not like vsync, because of the slightly increased input-lag… who really can noticed that 10ms, go with the solution without vsync and a max-fps…

But for the OP I also assume, that not gsync is the issue. Former he had 30fps max and so whole system had enough power… if he have now no fps limit, then may be…

1 Like

Might be worth digging into the monitor settings as well, check that Gsync / Freesync is enabled there in the on screen display menu.

Also are you using a DisplayPort cable or HDMI? Gysnc only works over DP if I recall.

ICan you explain exactly how to do it, I’m Italian and I translate

you can open nvidia control panel and choose 3d settings (1 in picture)

In (2) you can set global “limits” which used for all your apps , and in (3) you can set programm specific settings.

So it looks in my case in global (2) , because I use in-game vsync:

image

I have a MAX fps limit to my monitors fps and a Max Background FPS limit to 25 ( in case the msfs application is in background ).

For a first test you can of course limit in global (2) the max fps and try out MSFS. If that works , you can set in global a usefull fps max and in programm settings (3) the 30fps.

In programm settings you can choose Microsoft Flitght Simulator…

image