GTN750 Project

NEW GTN 750 RELEASE V2.1.39

See https://pms50.com/

  • Bugfix: right-click in map view engages the pan mode.
  • Bugfix: right-click in chart view engages the pan mode.
  • APGA: fixed an issue where the armed selected altitude may be bad. This bug occurred only in WTT mode if you try to set yourself the “AUTOPILOT ALTITUDE LOCK VAR” instead of using the dedicated APGA events to change the selected altitude.
  • Improved stability in WTT mode for VOR and LOC navigation.
  • Bugfix: Autopilot page: the altitude selector in the GTN750 toolbar panel was not working correctly.
  • Added an HDG line on the map page when turning the HDG knob (premium).
6 Likes

Thnx for your update,

really enjoy to fly better with my PA34 and with this product.

1 Like

Does anyone have an issue with DTK and DIS disappearing after activating an approach? Using the 310 WTT mod.

image

Nice !!! Thanks :+1:

but

Excited to try this … Updated to latest RELEASE V2.1.39, and fired up MSFS.

No HDG line — checked to see if was a congire Option and — it was because, updating lost my Premium Registration :fearful:
(1st time an update of the GTN750 has lost my Premium Registration)

I assume I can RESET that… but just noting, the update did cause my Premium Registration to get lost …

Just my bad luck, or is this happening to others, with this particular version update ?

So I finally get the Reg License code re-entered – would be so much easier if it was given in Blocks of 4 characters !!

All looked good, Premium working, Option to turn on/off HDG set ON

But No HDG LINE display when in Map Mode ( Bananna working )

Below is the Garmin Trainer, showing what the HDG LINE should display as

heading line with Arrow at end, length showing predicted position after xx Minutes.

The HDG line displays when you turn the HDG knob like in the G1000Nxi.

Is this known here, if you have installed “GTN750” and “TDS GTNXi”, that you can no longer click on anything in the TDS GTNXi? It would be nice if this conflict could be cleared up :wink:

As of today i installed the version 2.1.40 of the GTN750 and the Navigraph support seems to be missing for me.

I go to System / Setup / and theres no charts button anymore so i cant connect to navigraph and use the charts.

Downloaded the Version once again and installed it but still no charts tab.

I also had for the first time after an update to reenter the Premium Serial again.

What do you mean by there is no chart button? A screenshot?

I’m guessing this is an NXi or sim issue, but I just had a weird experience flying an LPV approach.

I just flew the RNAV33 to KRME, which is an LPV approach. It should give ILS-like precision needle indications, glideslope and loclizer. It seemed like the L/R needle did pretty much nothing (though I didn’t get far off), and the vertical guidance needle gave me stepdown altitudes instead of a 3-degree glideslope. I intercepted at the FAF about 100 feet high, and the needle was below me and never came up. I descended to try and catch it, and even at 1,200 FPM I couldn’t catch it. There is a stepdown fix (JERDA, 1,220 feet MSL) and the needle DID come in once I hit 1,220 FT MSL - but I was 3 miles from the fix! It basically gave me altitude guidance for a dive and drive LNAV-only approach.

So instead of giving me a glideslope it effectively told me when I hit the stepdown altitude and then I dragged it at 1,220 to the fix, then descended.

Try the Rnav 01 into KDCA. (this one works )

Some Rnav approaches in MSFS seem to not work, or are not fully compatible with the current GPS systems ?

I’ll have to do that. The variables here are the JF Warrior and the G1000NXi. I doubt it’s the 750 itself. If you get a chance try the RNAV33 at KRME.

Well, that was an Interesting / education Hours !! – attempting to fly the RNAV33 at KRME (with the Asobo FP system, not new WT system).

After several attempt, I conclude, IMHO, that this RNav Approach does not currently work in the sim.

Using latest Navigraph cycle … ( C172S MOD (steam) GNS530 / KAP140) “Enhanced”

GPS does NOT identify the FAF MARCY @ 2500, and switch to GS mode.

ILS works fine (as expected)

There seems to be many RNav approaches in the Sim that fail to process correctly, “MAYBE” because the Sim is not recognizing the FAF as being the FAF for the Rnav Approach ?

It can work correctly, and amazingly well with some Rnav Approaches,
ie Rnav 01 @ KDCA

I did make a video of the whole flight, but it is so messed up, I am not going to post it, at least till I determine it was the Sim messing up, and not me —
At least I can go back and analyze what went wrong, but I am already 95% sure it was the SIM’s processing of the Rnav approach, and NOT Pilot error !!

Anyone else found they can fly this Rnav Approach, without resorting to a WT based system ?? – consider this a CHALLENGE !!!

=== CORRECTION / UPDATE ======
OK, this IS my ERROR, the Topic is about the GTN750, and not the GNS530 !!

but at least I have possibly shown that it does not work in the GNS530 !!

2 Likes

Thanks for taking the time! I appreciate it. I haven’t flown all that many approaches in the sim, but even what I did served its purpose. Instrument currency flight at KRME went flawless today.

1 Like

The ILS works fine, but did you really find the Rnav 33 into KRME descended you on the GPS glide-slope ??

In real life absolutely, I’ve flown that approach a zillion times and it’s absolutely a glideslope.

Why do these MSFS posts get so messed up and confused.

IN REAL LIFE – yes of course… That Rnav approach is on the current “Real World” plates.

I thought this was a MSFS Forum, and we had been discussing what was working or not in the Sim.

In any case, you lost me at “a zillion times” !!
Kind of indicates you are not telling the truth !!!

BTW ( Zillion is not actually a real number:wink: !!

I thought this was a serious discussion. Never mind.

1 Like

re-reading

Instrument currency flight at KRME went flawless today. - Congratulations

but In the sim (Topic is GTN750 Project), it doe not work … and I just wasted over an Hour determining that - but now I understand what you are on about …

What you describe is what i saw, the Rnav approach tracked horizontally, but it was actually taking the LAST WP as the FAF, and descending you from there on a glideslope…

Seen this happen at many other Airports MSFS - Rnav01 KDCA being one, with WPs after the FAF, where it DOES work, and descends you from the FAF correctly on a Glideslope.

FSX Ghosts in the Asobo code ?

1 Like

I tried the KRME RNAV 33 in the RV-14 with the GTN750 but couldn’t get it to work. But in the Kodiak with the G1000, it worked flawlessly.

1 Like