Guimbal Cabri G2

This is the craziest thing I have yet witnessed in MSFS 2020. Deleting the rolling cache indeed solves the problem. The crazy thing is that I have set rolling cache to off, and that I need to delete the rolling cache for every new flight I take (even though, as I said, my rolling cache is off). Even crazier, I must do it in the following sequence. Start a new flight in the G2, take off (at this point the fps will be bad), then I hit esc, delete the rolling cache, and voila fps are good. If I do it before the chopper is airborne, no good.

Anybody else see that, or am I loosing my mind?

It’s not the A310, it’s not beaver, it’s not the DC-3…the Cabri is low-key becoming my favorite from the 40th anniversary party town.

With that said, i’ll probably say the exact same thing in the DC-3 thread and A310 thread as well about those aircraft lol.

But yeah, in summary, basically i love this one.

As for the Bell, not yet, i feel it’s got issues. Will wait for further updates.


OvertheEDj’s observation is 100% correct.

The G2’s rotor should spin clockwise when looking from above. Due to Newton’s law, the fuselage of the helicopter wants to spin in the opposite direction. You have to apply anti-torque pedals (not called rudder) to stop the fuselage from rotating. The more collectively you pull the more torque is generated therefore the anti-clockwise tendency will become even more.

1 Like

That’s what I said. You mean the animation is wrong? I doubt it.

Oh yes you are right sorry. I see you are both right. He said his Cabri turned counterclockwise. Therefore his Cabri’s rotor is turning clockwise then.

About this: With the new update, this became a problem again. I also saw this problem in the LS8 (sailplane) thread. A while agot, Asobo introduced a config option to force the modern flight model (regardless of what is set in the menu) but this option is not set in some of the new aircraft…
I created a bug report about this, please consider voting:

Where is that force trim command please?? I can’t find it anywhere in controls.
Thank you!!

G2 doesnt have Force Trim. Only normal rotor trim.

Also see bug report about Force Trim

1 Like

Microsoft and Sergio Costa from had a helicopter stream last night. Sergio was explaining the basics of helicopter flying and was using the Guimbal Cabri G2 in MSFS to demonstrate. There are some great tips.

Here is a link for those who haven’t seen it:



There is an issue with the power set according to the MLI and the corresponding rotor droop when pulling too much collective.

In the screenshot you can see the NR decaying into the lower yellow arc, while the MLI still only reads 77% in FLO mode. The power should not run out below 100% and the governor should keep the NR up until the throttle is fully open and the engine produces maximum power.

I presume there is an issue with the MLI power indication, since the throttle seems to be fully open at 77%, which should definitely not be the case.

Also I found it impossible to pull more than about 83% with full collective up, which doesn’t make any sense.

1 Like

I’ve only had a couple of hours on the new helicopters, but very impressed so far. Yes, a few tweaks to control mappings and turning off all the assists were required to get them to my taste and the forums helped a lot.
The standout feature that I would like to see implemented asap is the ability to autorotate and have to manage the rotor speed as in real life.
There is much work to do, but a great start for us long waiting rotorheads. Thanks.

Many people have already been able to auto rotate.

HOW TO START A CABRI G2 HELICOPTER - YouTube Just wanted to share this video I found.


Absolutely, a TDS GTNXi 650 integration is available:


Is that true autorotation? ie being able to separate the rotor from the engine. Can you point me to a video showing that please, perhaps there’s a mod out?

My experience so far on the sim is that the rotor needle just stays in the green no matter what you do, which is not autorotation. It’s as if there’s no freewheel. if I suddenly lower the lever in the real aircraft I would expect the Nr to increase rapidly to show a split and would need to control it within limits with the collective.

Anyone seeing any spawning/launch flight issues with the helis/Cabri?

It may just be with custom airports, but I’ve had quite a few issues where depending on where you pick (gate/runway/parking spot) to spawn at, the loading flight screen will just sit there and load forever, but never launch the actual flight.
It’s only with helis I’m seeing this & mainly at custom airports although some are default, and it’s mostly been the Cabri I’ve been using.
It’s annoying because there is no way of telling what will work and what won’t (airport/spawning wise) and I have to end up killing FS from the windows desktop when it happens as there is no way back.

There are also some helipads with issues. If you pick the helipad like its a runway and hit set as departure without picking an actual spot, you can spawn atop of the heliport building roof.
If you want to see this in action try spawning at Manhatton heliport for departure without selecting a parking spot.

We have updated the Known Issues list with a couple workarounds for helicopters:

  • Uncontrollable helicopters because of Legacy Flight Model Gyroscopic Precession not at 100%

    • Workaround:
      • Set to the “Gyro” to 100%
      • Open Microsoft Flight Simulator
      • Go to Options > General Options > Flight Model.
      • Change to Legacy.
      • Set Gyro to 100%. Hit Apply and Save.
      • Change back to Modern. Hit Apply and Save.
      • Start a new flight.
  • Loss of pitch control in helicopters because Anti Stall Assistance is enabled and helicopter pitch assigned via elevator control.

    • Workaround 1:

• Set Anti Stall Assistance to Disabled

  • Open Microsoft Flight Simulator

    • Go to Options > Assistance Options > Piloting
    • Set Anti Stall Assistance to Disabled.
    • Hit Apply and Save.
    • Start a new flight.
    • Ensure proper nose-down trim on take-off in the Cabri G2
  • Workaround 2:

    • Assign helicopter pitch control via the dedicated longitudinal cyclic control rather than the elevator control.
    • Ensure proper nose-down trim on take-off in the Cabri G2

When you turn off the governor when autorotating the rotor RPM does not stay in the green, and I manage rotor RPM with pitch. When I practice autorotations, i switch off the governor, and close the throttle all the way. Not sure what the correct technique is for practicing autorotations. Maybe a helo pilot can chime in here…

1 Like

great info.

where did you find the G2 manual?

A little off topic … but for all “Hotas Warthog Joystick” users
For me, this video was a game changer for helicopter flying.
If you don’t like it, you can simply set it back to the default state.

1 Like