GX3 not responding to Reference Altitude setting

I’ve asked this before, but no responses. When using the only two aircraft I know of that have Garmin GX3 avionics (the Cub Crafters Cub and the ICON A5), every aspect of autopilot works with the exception of altitude control. The aircraft simply continue to climb above Reference Altitude, climbing above the Bug, and past the flashing approaching altitude alert, either ascending or descending. I’ve tried this with only MSFS versions and with the Working Title mods for GX3. I’d think it would be a simple PID algorithm, current altitude vs. Ref altitude and output of the algorithm is sent to the elevator pitch. However, there’s no apparent output to pitch, regardless of Foot Per Minute setting. I’m not informed enough to even know what I’m looking for in the configuration program (parameter set to ‘0’ when it should be ‘1’, etc.). I think I should be looking for parameters like ‘Elevator’ or ‘Pitch’, but I don’t know where to look or if I should even waste my time and just accept the two aircraft are essentially fly by hand.

Interesting. I did a couple of flights post Hotfix and ALT hold with a target level using VS on the CC19, no problems. I get the warning beep within 1,000’ and then the flashing, then the level off.

Forgive my ignorance. CC19??

I believe the official manufacturer designation for the Cub Crafters XCub modeled in the sim is “CC19-180” or CC19 shorthand.

I just tried it again. For the record, I have the following up-to-date (as of this post) Mods installed:

Navigraph Beta with AIRAC 2103
Mugz TBM 930 Performance Mod
Henrik’s Global Ship AI
Working Title G1000
Working Title G3000
Working Title G3X Dev 0.6

Screenshots showing Altimeter Capture at 2000’, I am in NAV Mode, VS with a 300 fpm climb rate. Prior to engaging VS, I was trimmed for as low an ascent rate as possible, before engaging NAV first, making sure it started tracking towards the leg, then dialed in 2000’ target, then 300 fpm, then engaged VS. You can see in the sequence the fpm rate dropping as expected as the target ALT gets closer.

This is not intended to say that you’re not having problems. I’m positing a scenario (hopefully simple enough to recreate) to see whether there’s a step there that can help you troubleshoot.

1 Like

Thanks for the quick reply! I’ll give it another shot, but I’ve tried ascending at 100 to 200 fpm, 50 to 75 IAS and it just continues to sail past reference. Oddly enough, both G1000 and G3000 avionics work fine. I am truly at a loss. One would expect the algorithm for the G1000/G3000 altitude hold to be the same or close to the same for the GX3, but that’s not the case in my instance. If I figure it out before I’ve pulled what little hair I have left, I’ll let ya know. Once again, thanks for the reply!

1 Like

Try pressing B on your keyboard, sets the altimeter pressure to whatever is the actual one.

1 Like

Do these aircraft actually have an autopilot in the cfg files? I‘ve never checked that, these type of aircraft normally don‘t have any as they are already very weight limited.

1 Like

Not sure if the actual aircraft can be so equipped, the MSFS versions are…

True. Setting barometer has a definite affect on the altitude targeted by the G1000/3000 series and should on the GX3 as well, but makes no difference. Good suggestion, tho…

You could try the G3X Mod from Working Title and see if this fixes the AP for you.

1 Like

Thanks, unfortunately the mods have no affect on the problem. I’ve tried them in various combinations, i.e., workingtitle-gx-fixes (from the ICON Performance file) and workingtitle-v0.1.0-dev6. I’ve drilled down through the included folders looking for mention of Pitch or Elevator and can’t find any parameters or attributes that might be turned off for some reason. No luck, still don’t understand why the G1000/3000 work but the GX3 doesn’t. First noticed the problem trying the mod for the ICON, and posted about it when that came to light, several members offered advice, but nothing seems to work. Not sure if I should bother the folks in the workingtitle discord or not, seems I’m the only one having problems with this feature. Thanks again!

Have you tried it in various different speeds? If for example the aircraft is flying close to overspeed, it will keep climbing in order not to overspeed.

Yes sir. Latest attempt this morning was with CasualClick’s Comm folder contents, G3000, G1000, and G3X ver Dev 0.6. Set Reference Altitude to 8000, VS to 200 fpm, ascended to 7800, leveled off at 65 KIAS and watched the Cub continue to happily keep ascending well past 8300 with no sign of returning to Ref. Typically, indicated vertical air speed will drop off as you approach Ref, but not in this case, VS just keeps rising. I think the only reason I can hold altitude is by prop and throttle manipulation. The G3X seems to have no authority over the elevator pitch setting. Thanks for the suggestion!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.