HELP - all my trees disappeared

Anyone have any idea why my world no longer has trees?

Start up the game. At the top right, select your account and log out. Then log back in again. Remember to use the same login that you used when buying the game. If that doesn’t work, try also logging out and back in again for the Xbox for PC app and the Microsoft Store app.

have you “climate change” enabled in weather settings?

sorry, couldn’t resist, no further meaningful input

Nope. Didn’t work.

Thanks for trying

I didn’t think climate changed worked that quickly. One flight they’re there, the next, they’re gone.

Then for something more meaningful though still the usual standard questions:

  • did you do ALL updates, i.e. also those in the Content Manager after applying the patch?
  • did you install any mods recently if so the delete / rename temporarily your community folder
  • did you actually reboot your system and check again whether trees are still gone
  • you may also empty/delete the rolling cache fwiw just to rule out something weird is stored there

since now you say sometimes trees are there and sometimes not, double check the tree settings in the graphics menu, maybe deactive them or set them to low, restart, check they are gone and get back to medium, high etc.?

No they were there, and suddenly not. Not that they come and go. Just one flight, they were no longer there.

Check if you’re still logged in with scenery streaming.

Ok.

I did all those things and nothing worked. I had no mods anyway.
I deleted my rolling cache and the trees returned.

No idea why.

Of course I noticed that manual cache was no longer an option. So I don’t know what was done there.

Rolling cache does have problems for some. Will even cause CTD’s. I think there needs to be a way that Asobo verifies those files as they seem to get corrupt easily.