Honeycomb Alpha Avionics BUS1 switch has no effect in X-Cub

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Nope, all broken and gone since SU5.

Are you using Developer Mode or made changes in it?

Brief description of the issue:
When flying the X-Cub since SU5, you can not start AV Master using the HC Alpha. One has to use the mouse.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
See above. Take the X-Cub and try to start Avionics with the Alpha

Build Version # when you first started experiencing this issue: (as if I have a choice here)

Are you on the Steam or Microsoft Store version?

Did you submit this to Zendesk? If so, what is your ticket #?
Gave up a long time ago.

As a temperary measure you can use me XCub mod here… It will fix the issue until a patch

1 Like

So far I try to stay away from all mods except the Working Title ones. It really looks like the modding community was caught by surprise and didn’t get any upfront notice. No mods for right now, I had enough CTDs.

I can respect that. But if you change your mind you should definitely try it. I’ve been developing it for the better part of a year.


Have you tried the Bus 1 switch using any of the other single engine aircraft?

I was having the same issue with my Alpha yoke and the Avionics Bus 1 switch in the C172 today. Oddly, I also have the Bravo throttle quadrant, and the far right switch on there, did actuate the Bus 1 switch. On the Bravo, that switch is set to something else, though.

As far as my Control settings are concerned, the Alpha Bus 1 switch is set to actuate the Bus 1 switch in the aircraft.

I’m actually here to see if anyone else was running into the same or similar issue before I started fiddling with my own Controls settings.

I guess I’ll play around with it a bit and see if it warrants a Zendesk ticket.

Good luck! Keep us in the loop on your progress.


After a few restarts and some settings adjustments, I was able to get the Avionics Bus 1 switch to work in the C172 (G1000).

However, I was not able to get it to work in the X-Cub. But I also didn’t want to go too deep into rearranging my settings for something that did work prior to SU5.

I looked into the systems.cfg of the XCub and it’s much simpler than some of the other default planes. It doesn’t seem to have any electrical busses, just circuit configurations. The panel switch maps to AVIONICS_MASTER_SET, so if your hardware can toggle that event, it may work.

Interesting, so it’s about mapping that in addition to BUS 1 / BUS 2. Since the HC Alpha has two switches I’ll bind the combination to AVIONICS_MASTER_SET. Regardless, it used to work just fine before SU5. The starter never worked though…

So I did try this and does not have any effect. In fact I tried every combination possible, “SET AVIONICS MASTER”, “TOGGLE AVIONICS MASTER” and mapping to the individual switches instead of the SET ones. It’s just a bug in that plane.