Honeycomb XPC issue with XBOX

Hello everyone,

I got my XPC yoke last week. I connected the yoke to XBOX, and then connect Bravo Throttle to the yoke through XPC Hub. The yoke worked well, but there are many issues with Bravo - lots of buttons are not recognised by FS software. I opened the controller setup, and tried to assign buttons, the FS software cannot find the button that I clicked when it scans any clicked buttons. Anyone got similar issue like me?

Looks like everyone who has received their XPC and tried to run their Bravo through the Hub is experiencing this issue as well, to the point where it looks like it just does not work at this time.

Conversation at this point switches to whether this is technically possible on Xbox without the PC drivers that enable the lighting, and how many of us can mob up and make enough noise to Honeycomb/Asobo about enabling this implementation.

Taking delivery on mine later on today, I’ll reply again if mine work, but I am assuming they will not.

I’m having the same issue. Throttle/prop, and mixture register as do flaps and gear but no lights and all other switches are dead. I guess that’s what we get for being out on the bleeding edge. Hope everyone is sending in reports on the Honeycomb support line.

Hi @Red81Trekker @HalfPandora788 Thanks for your information. If it is software/driver/configuration issue, then should be able to be fixed by updates. I noticed FS in my XBOX got some update and the controller panel for Honeycomb had been updated too. Some button on yoke works as expected now, but still some buttons on yoke and most buttons on Bravo do not work.

I also found a video on YouTube: XBOX B747 XPC - YouTube about playing XPC with XBOX, looks it is working well. I emailed Honeycomb customer support. Hopefully it can be fixed soon.

Thanks OutrightCupid76, for the info.

So woke up at 4 a.m. with this thought… Since the switch on the back of the Alpha can flip from PC to Xbox, it stands to reason that the drivers loaded have to cover both eventualities. So it ought to be the case that if you connect the system to your PC (I would set the Alpha switch to “PC” before doing so) and run the config file from the Honeycomb site, it should update the whole thing - including any Xbox changes. Reconnecting to the Xbox (and flipping back to “Xbox”) should then load as current a set of settings as is available.

Sorry I can’t try it that way as I’m on a Mac but I intend to download the X-Plane drivers and see if that route will kick in Xbox configs anyway. Post if you have any luck!

1 Like

Very interesting. Hope someone can try this out and see if it works!

I have the XPC and the Bravo connected via the new Hub. Nothing at all registers on the Bravo.

Curious, did you get the Bravo to work with the XSX and Hub?

Anyone try running Logitech rudders on Xbox yet, via the Honeycomb hub?

Logitech rudder pedals are supposed to work. As well as Thrustmaster. I think the current issue is that the hub doesn’t work properly or at all.

I (think) I just tried to correctly do this, per the macOS Honeycomb config tool and Xplane 12 demo, and it did not work. Alpha XPC was set to PC mode. Honeycomb plugged into Mac by way of hub, not directly.

Hey Red, I tried that as well and got the same (non) result. I think the strategy should work on a PC when the MSFS files can be used rather than X-Plane.

Hey Kermit, my Bravo is “working” in the following sense… I have full control with the throttle/prop/mixture levers and have configured them with no problem. Likewise the gear lever and flaps have been functioning. What is not working are any lights nor any of the switches - MSFS does not react to them at all. I’m at the point of flying with things the way they are since the switches are a “nice to have” option but not essential to operation. I’ve lodged a ticket with support (hope everyone does that also) and will report back if/when I hear anything.

Wonder if I can try on the PC Gamepass version of MSFS. Not ideal, but I’ll give it a shot. My PC is a dinosaur and I’m pretty much Apple only with everything.

Zero recognition on any black aux switches on the Bravo panel. Anyone else?

Interesting that you have 3 levers working on the Bravo. I could only get the single engine throttle to work when I disconnected the rudder pedals. Obviously something is very wrong. Doesn’t appear as if they have added proper support in the software. When you say ticket, with Honeycomb or Microsoft?

Some update: I also tried XPC yoke + Bravo on my MacBook with X-Plane 12. They worked well, though I need to configure the profile to map buttons to correct functions. All buttons from yoke and throttle can be recognised by X-Plane. It is pretty sure something is not configured properly with XBOX. :neutral_face:

I ticketed Honeycomb.

Also, just to be clear, all the levers on the Bravo are functional for me.

1 Like

I would be interested just what rudder pedals work with xbox xs and Bravo. Honeycomb say only Logitec Thanks Graham