HOTAS Controls stop responding every 2 mins

Hi, i got the game a while back but finally got my hotas mounts printed and booted up MSFS and started the training tutorials in vr and my throttle, fuel mix, yaw, brakes and many other controls stop working and i had to press escape for them to update and work for another second or so then for them all to freeze again. i joined the discord earlier and was tols i could press CTRL+0 to restore control and that works however i have to do that every 2 mins and during a tutorial when there is a lot going on in say something like a landing procedure i cant afford the few seconds it takes to find ctrl+0 and take my hands off the controls. whats worse is this happens every 30 seconds - 2 mins and there is no controling the interval. this only happens in VR mode from what ive found…

1st thing that come to mind – Is your USB port set to power save Mode, and is shutting down on you ?

WILD GUESS … Please do not shoot the messenger if I am wrong !!

no, first thing i checked was the usb port and its only in VR mode, not normal mode leading me to believe the problem is the game, not the hardware or software, wince it works fine in elite, tinker pilot and star citizen.

Lots of things seem only not to work in MSFS for some, but for others, all works well –

Its an “interesting” situation – or should that be “a frustrating situation” !

Try running MSFS in windowed mode and open windows device manager. Look for strange behavior in the device manager, like devices disconnecting and reconnecting.

Some devices don’t like some usb ports. Some devices don’t like hubs.

Taking my Z690 Intel board for example, some of the usb ports are connected from the CPU. But some of the other ports are connected from the Z690 chipset. I have a USB hub that doesn’t like being plugged into the Z690 ports, but works fine in the CPU ports. I have a logitech FIP that doesn’t like the Z690 ports, but works fine on the CPU ports.

You might have to try putting the high load devices or more complex devices on different ports.

Firstly if you are on AMD Ryzen, there is issue with that system and USB drop out. Update bios and retry on default set up.

and secondly have you checked to see if there is a switch permanently in the active position?

its not a hardware problem, like i said, this ONLY happens in MSFS VR mode. not 2D mode. ruling out anything todo with hardware or software. it works perfectly fine in 2d mode. also, again for those in the back, the usb port was the first thing i checked. also, its on a powered hub, there is no power drain issue. it has a full 12 amp source to pull from and only my vr controllers plugged in to that hub, they pull a max of 2 amps leaving 8 amps for the hotas, pleanty of overhead.

Again, no, this isnt a hardware issue, the fact this is only happening in MSFS, and only in VR mode should be a big indicator, does no one read on this forum??? ive had my hotas for 4 years. there is no enable or disable switch. I am on Ryzen byt my bios is fully up to date, again. this would be a problem in other sims/games but it isnt, the issue isnt with my hardware. its with the game.

Still may be a hardware issue, even it is working on other sims. MSFS is brutal with hardware usage. It maybe causing power dips on the SOC, which controls board interfaces. I would track it in HWinfo as a starter, mainly focusing on voltages and dips.

1 Like

powered external hub. :eyes::open_book: unless something is making it draw 8 amps without the magic smoke coming out, then the issue isnt the power.

Presumably your VR kit uses USB to track position and possibly also deliver USB audio?

FS2020 adds to that by being DMI heavy in its own way. Network streamed visuals, constant read/writes to storage if you are using rolling cache etc.

Being able to saturate the DMI sounds pretty absurd when you say it out loud, but depending on your system your DMI may only be x4 lanes of PCIe 3.0.
Saturating a USB Host controller on the other hand might not be so hard.
Combine the two and…

Could it still be Asobo’s code? Yes. Absolutely. But don’t overlook Hardware also, because there isn’t another game I can think of that essentially streams the entire experience.

1 Like

i would agree with you if it werent for the 3 following things.

  1. I play Elite and Star citizen one i run in VR and it forces the same load during planetary flying and i have no such issue.
  2. Its on an external hub on a different controller, meaning bandwith isnt the issue
  3. I also tried lugging it into the PC Directly also on a seperate controller dedicated to a single USB 3.0 gen 2.1 port and nothing changed.

Also IIRC, the Index does audio Via the HDMI from the GPU, the USB port is for the dedicated tracking and bluetooth controller.

Elite Dangerous does the same thing via the OpenXR framework too, if anything it does it worse.

A powered USB hub will not fix issue if they occur at the SOC.
Good luck sorting it though.

CPU has 16 PCIE lanes, dont think its saturated.

sofar it seems only yu has the issues, altho still recent post.
if its the game , many others would have the same issue.

The CPU to GPU interface is 16 lanes.
The rest isn’t on that path.

On Ryzen there are x4 PCIe for the chipset and x4 PCIe for USB/M.2/Sata (these are in addition to the x16 GPU lanes)

Yes. It can always be the FS2020 software, but a good, easy test of the hardware would be to turn off the rolling cache, turn off all online functionality (bing maps, photogrammetry, Azure ATC etc and test in VR, this will reduce network and storage I/O load)

ill give that a go…

I have a similar issue and wrote up this post:

Like the OP mentioned, this ONLY happens in VR. I’ve tried different ports, bought a powered USB hub. My issue happens whenever I start a flight, it drops most, but not all USB hardware. It’s almost like it’s loading a different peripheral config up until I manually go into the controls dialog. I have also seen it, once, where I went into the controls dialog and it showed the button mappings for one of my controllers, but no items listed in the controller slider at the top… not even the mouse and keyboard, even though those were working (or I wouldn’t have been able to get to the controls screen).

I’m also on a Ryzen and using a Quest 2. Can you explain where/how to turn off the rolling cache and what that does?

2 Likes

I found the rolling cache options. Tried playing with it turned off as well as upped to 50GB. neither effected the controls dropping out.

One other thing I noticed… I have Active Pause and normal Pause mapped to two buttons on my yoke. When MSFS drops my hardware, the yoke remains active but the Active Pause button doesn’t work. The normal Pause one does. When I go into control options and back out of it they both work again. This is making me think harder that some other hardware profile is being loaded or overwriting my profiles. Is it possible that MSFS is loading up some VR controllers or something that it isn’t telling me?

For those following this and if this is helpful… my current procedure when flying in VR is:

  1. Go into VR
  2. Start a flight
  3. Pause the game
  4. Go into control options (no need to change anything, just let it load and display everything)
  5. Back out of options back to the flight
  6. Hit Active Pause
  7. Hit CTRL-1 to show the dashboard view so I can move Nav Log and any other panels I have open
  8. Hit CTRL-0 to go back into the main view
  9. Toggle Active Pause off
  10. Fly away!

I do this for every flight. It’s not horrible once you get used to it since I’ve mapped buttons to most steps, but sure would love it to be smoother.

i tried everything you suggested and no luck.