How do I stop accidentally quitting the sim while in VR?

This is driving me nuts and I’ve not seen it mentioned.

In VR, when you move the in-game cursor, the cursor on the 2-D monitor also moves. This 2D cursor is allowed to come out of the cockpit and interact with the buttons on the Flight Simulator window title bar.

In several flights now, when I try to click something above and right of me (e.g. the autopilot controls on the CJ4), the 2D cursor clicks the X to close the sim.

The sim then quits with no warning/confirmation e.g. a ‘Are you sure you want to quit?’

This usually happens when turning the autopilot on during climbout, after 20 minutes of setting the aircraft up, taxiing, checklists etc. It has ruined a few flights now.

Has anyone else had this problem?

Surely Asobo can just add a ‘do you want to quit?’ option or keep the cursor confined to inside the window so it can’t click the X on the title bar.

weather is not working at all in-flight sim on my end.

Enter full screen first - Alt + Enter, then go into VR

2 Likes

I’ve been wondering about this myself, just haven’t had time to research. And going full screen isn’t always an option. As best I can tell, full screen can’t be used in conjunction with Pilot2ATC’s program.

I get around this problem by moving my head a little so the click point is nearer the centre of the screen, and quite distant from the corners of the FS2020 window.

In some cases you might be able to assign a control stick button to avoid having to use the mouse.

Never had this issue im 5 years of VR flight simming. My cursor is confined to the game window which is not full screen. I have to alt-tab if I want to interact with the title bar or other windows

It is for this reason that I no longer run FS2020 in windowed mode in VR. Run it in full screen mode, no more accidental program closures.

I actually submitted a ticket for this a few month ago, when I clicked on overhead buttons in VR the sim used to close - I reported the bug.

Little did I know I was closing it myself on pc monitor.

Turn on full screen mode in graphics settings

Thanks all for the tip on full screen. It makes it a bit more painful to look at other windows during the flight prep like Simbrief, the Brunner joystick program etc but once I’m in it works and the full screen stops any risk of accidentally quitting.

Still seem silly that you can close it by pressing the X button with no confirmation.

Do you have issues with the mouse losing focus in VR while using Pilot2ATC?

Yes, I lose focus, move the sim window when dragging in game panels, and close the sim by hitting the x in VR. And running full screen isn’t an option if you want to use Pilot2ATC, which I do.

Like I said, I haven’t done a lot of research yet on if there’s a way to fix it, I’m working on a few other things first.

Same for me. The pointer is locked inside my small 1280x720 border mode window when I play MSFS in VR, and my TV is FullHD. The cursor can’t go out without me alt-tabbing first, so I can’t click accidentally outside and lose focus or even the cross to close the sim… Weird we have such difference…

Make sure this sim is in full screen mode. When it runs in window mode the mouse cursor can escape into other windows outside the sim.

I just drag the window a little bit and move the X out of the screen.

Yes, this is weird and annoying. Initially I though the gave was crashing. It took me a couple of times before I realized what really was happening.

In VR I never had the Sim in fullscreen, windowed and smaller than my screen, and never had this issue, mouse stay inside the window whatever I do unless I alt-tab. It’s weird we have such different behavior.

I notice if I have other windows open, then sometimes the MSFS window is not in focus and the mouse can go outside the MSFS window… purely because it is not inside it. If I bring the MSFS window in focus on screen, then the mouse is constrained to the MSFS window.

On my system, with the FS2020 window active, the mouse can’t go beyond the client area, except for 1 pixel at the top, which is sufficient to interact with the non-client area icons (close, system menu). As a matter of fact, sometimes I right click to zoom and this freezes the game in VR, only because this accidentally opens the window system menu (Restore, Move, Minimize…)

I’ve finally had some time to play with this and I’ve figured it out a little bit. Not necessarily a workaround or fix, but a “partial sorta makes it better” kinda thing, along with an explanation.

With the sim in windowed mode, you’ve still got two options. Either that window is maximized, or it’s not maximized and the window can be moved around. This is where the problem lies.

If you’re maximized, the mouse stays in the window and won’t “pop out” to close the sim. But, when you are not maximized, the mouse does go out. The easy fix here is to just make sure the window is maximized, but there’s still a problem.

I use the In-Game Panels pack, but there are several other panels like ebag, etc. It might even happen with the sim panels like atc, checklist, etc. When you open them in VR, they’re right in front of your eyes, but you click on the panel and drag it to the side. That clicking and dragging, if your mouse happens to be up right at the top of the windowed mode, moves the window, thus taking you out of the maximized window. Any future clicks after the click and drag have the possibility of closing the sim, the sim losing focus, etc.

So, make sure you’re in maximized windowed mode, and be careful with any click and drag elements near the upper side of your vision. That should lessen the issue greatly.

Hope that helps, sorry if it got long winded.

You have two choices here, one is absolute and the other is picking the best way to avoid accidental activation of other desktop interactions:

  1. First the absolute fix : goto Home>Options>General>Graphics (in msfs2020) and chose “Full Screen” instead of “Windowed”.
  2. If you need to have MSFS2020 in windowed mode then avoidence is your next step: Push the minimize button on top right side of MSFS2020 window untill it slightly moves inward. Then grab the corner of the window and shrink it to the smallest size and place it on the screen in the least used area. Place all your desktop icons into one folder and put it in the same zone or area of your desktop. Then make your task bar “hide” by right clicking it > choose “Taskbar settings” and hide it. Now you have produced the smallest hit zone possible and you know where it is at; Stay away from that area in your cockpit !!
    I agree with you that it is aggravating that it does that to the background desktop. I own the HP G2 VR headset and it places a tag at the top which indicates that you are either in desktop “mouse active” or you are in headset “mouse active”; but it lies!!! It is stil active in both places !!!

Mmmm, I don’t use the mouse that much in VR so it’s possibly why I didn’t catch this one pixel overlap (my zoom is on my stick).
I also play E.g. Elite Dangerous, Stars Wars Squadrons, IL-2 etc. always in windowed mode on monitor when I’m in VR, never had this issue, mouse stay inside (but probably with this one pixel gap, I need to try).

In any case, as we have several different behavior here, annoying ones, Devs should probably create an option to lock the mouse inside the window for sure. (VR wish list where are you?) :wink:

1 Like