How to get Rid of Rubberband Effect / Jitter /Judder in VR

I hope this tip i found out helps many VR users:


I just found out that the rubberband/jitter can be also avoided by starting VR before loading the flight. It seems that switching in flight to VR causes much problems, it seems that the game wants to catch up lost frames from the triangle effect or so… Much easier than the tip above.

1 Like

I’m finding the rubberbanding incredibly annoying.
I still get it if I reduce render to 848x848 which tells me it’s maybe an openxr reprojection thing going on as a 3090 should be smooth at that res (even a potato pc should run smooth).
Sometimes raising render scale a bit fixes it for me.

yes, this is only with reprojection. Without Repro, no Rubberband. By the way, i have a 3070Ti / 5800x and after using the mentioned tricks i get smooth repro until 2200x2200 (Photogrammetrie) or 2800x2800 (rural areas) [OXR 100%, latest preview off]. But i have to switch to 30% at first and get rid of rubberband by switching tasks or so. Then back to 75% or more.

Yesterday i tried setting “Mode for low Latency” in NVidia Control Panel to On, and pre-rendered VR pictures (last entry) to “1”. It seems this helps in getting rid of the rubberband effect when using reprojection. Please try for yourself!

Hi, as u talk about rétroprojection i take the opportunity to ask which setting is activating rétroprojection?
I hear about very often and never understood where can activate it or stop it.

For WMR Headsets like G2: go to Microsoft Store and load Windows Mixed Reality-OpenXR-Developertools.
Start it, then you see this image where you can activate (i use “automatic”) motion reprojection. For me this is much better because you get no double pictures on fast moving scenery - it is really smooth then.
But you have to dial down your Render Resolution in the sim perhaps, to achieve always at least 22.5fps. When its getting lower you see stutters.

Ok thanks but what about quest 2 and Oculus, they don’t use openxr i guess…

i dont have it, so someone else has to explain. But as far as i know, FS2020 only uses openxr. And the other headsets also have to implement this (perhaps with steamvr for openxr?).

Better performance can be obtained in steamvr using openxr.

This unfortunatelly is not true. Tested and proven multiple times in the past. You do get much less motion reprojection artefacts through steamvr, but the performance is worse

Not on my system…I get 45 fps steady… preaty much throughout. Witn OpenXR frames get locked at 30. One other good thing is I can adjust the world scale so the cockpits don`t look toy like!

This might be a little bit counter-intuitive, but try this cause it’s working for me. Turn your “pre-cache offscreen terrain” to Ultra, then find the sliders for terrain and object detail and turn them all the way down. See if that gets rid of the stutter. Then gradually push those sliders back up as high as you can go before you get the stutters again.

It’s not about your GPU, it seems to be a cpu bottleneck on caching world data. Not sure what cpu you have, but mine’s only a ryzen 5600x.

Although I said it’s not about your GPU, there seems to be some kind of negative interaction with ASW on Radeon cards, if the pre-caching isn’t working well., and I think that makes the stutter much more pronounced.

Using the latest version of openxr (108.2109.10009 - released this past weekend) with motion reprojection ‘always on’ made a huge difference with my Reverb G2. Very smooth game play and essentially no jitter. Make sure you monitor your rig’s performance using task manager. I’m keeping my CPU around 40% utilization and GPU at about 70% utilization. My goal is smoothness not FPS.

1 Like

I alway leave it on Motion reproduction on “auto”, I’ll try “always on” but last time I tried it didn’t work as good as “auto”.

G2 here WMR always reprojection disabled, or I get tearing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.