HP Reverb error on powering on

When I purchased the headset about a month ago, it worked fine and I only had to reconnect the usb or power every once in a while when the check the display port error appeared. Now I have to manually switch the display port cable to a different port to get it to work after reboot… every time. I contacted HP and they told me this:

Me…

I’m confused? So you are saying that it is standard procedure for every person to have to disconnect and reconnect their headset every time they reboot… crawl behind their computer every time you use it. I’ve had Oculus headsets and never had to disconnect. That can’t be right?

Response

Final word on the Reverb: If connected at startup, it can cause various issues within the system. The proper way to connect after restart is to plug in USB+DP, then connect the headset to power.

Often it should work if you only disconnect the power to it when you restart, so if that is not working then that possibly could be an enumeration issue if you have a large number of devices connected. However the proper way to connect is still to wait until after the PC is restarted

So in essence, they said my headset is fine and I should reconnect all cables after every restart of computer. How can that be? What are you thoughts?

Sorry I can’t help with a solution, but just as a point of reference, I have been using the HP G2 for about 3 months now and have not had to do what HP suggested. The G2 always connects as soon as I turn the computer on.

I leave the G2 plugged in to both the computer and the external power connector to the G2 headset all of the time.

It is probably more to do with the USB port handling in your Windows.

I have that tissue with my trackIR camera sometimes and ended up buying a USB 3.0 hub with a switch on each USB port. Now if i get problems I just hit the switch instead of needing to unplug and replug my trackIR.

Problem is I cannot just disconnect the USB and reconnect. The ONLY way I can get it up and running is to disconnect the DP port cable and plug it into a different port. Here’s what I have to do.

  • Restart the computer
  • I get the error
  • If I disconnect the DP cable and reconnect to the the same port, it doesn’t work
  • If I disconnect the DP cable and connect to a different DP cable port and it works
  • It never works plugged into the same port twice in a row

Even if I unplug the cable before reboot, then start windows, then plug back into the same port… doesn’t work. Plug it into a different port… bingo it works.

Weird huh?

i have an oculus, but there’s an issue where the USB3 port may not be sending enough power to the headset, thus shutting it down in the middle of playing (if you get that far sometimes). By going to the device manager and ensuring your USB3 controllers are set not to turn off to save save tends to solve this problem for the oculus.

I know its an Oculus is not a Reverb or anything and I’m unsure if this will help, but might be worth giving it a try.

Thanks for the suggestion but I’m sure it’s not a USB power issue. I have tried powered usb hubs and I have a type C on my motherboard. I’m not getting the usb error, only the dp port error. I also have all the usb controllers set to not turn off to save power. That’s one of the first things I do when I set up windows.

Probably not possible, but anyone know a way to disable and reenable a “particular” dp port inside windows?

I had the same issues with the usb connection, and yes, HP Support obviously doesn’t know a solution. In my case, I got no answer from them, so mine went back. Now I have the quest 2, it’s a compromise, but yes, it is working without problems. HP has to improve their product, but what they are doing, is selling their buggy headset on an on. So sad…

I never had an issue getting my G2 connected. However, I have mine connected to a switched wall outlet, which allows me to turn my headset on and off.

From what you wrote, HP is not telling you to unplug USB and DP, just power.

I have read many times about the USB error. That symptom also cause the dp error. But… I’ve never heard of anyone having to switch the dp port socket to get it to work.

Something weird here. Possibly windows is setting the display port to some setting or refresh rate that it later is incompatible with and cannot detect ?

Is Displaylink involved in this somehow ?

No Displaylink…

I occasionally have this issue. What I found is that if you open Device Manager, you can disable the G2, then enable it and it will work properly. To make it easier, you can create a PowerShell script to automate the process.

I’ve tried that many times. I even uninstalled headset and hololens, rebooted and still have to switch display port.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.