HP Reverb G2, cockpit shaking since installing windows 11

You can turn HAGS off in Windows 11, too. It’s hidden away inside several settings folders:
Settings–Display–Graphics–Change Default Graphics Settings–Toggle HAGS on/off.

Did a clean install of Windows 11 and HAGS is NOT turned on by default. You have to turn it on manually, if that’s what you want. I tried it both ways and the shaking is still there.

There was a new version of Openxr released yesterday and with the latest Preview Runtime turned on the FPS and clarity has shot way up for me but the shaking is even a bit worse. I suspect this is either related to OpenXR, WMR or a combination of the two.

1 Like

Same for me still. Windows 11, latest OpenXR. HAGS Off and shaking just like in the video above. This has been the case for a while now, even in Windows 10 it was the same before I updated to Windows 11. Looking forward to a fix!

Yeah, it seems the only way is go back to Win 10. With HAGS on or off in Win11 the issue persists.

Just popping into the thread to confirm that the disabling of HAGS fix appears to have worked for me. Just completed a completely smooth 30-minute-ish flight – no nauseating jitter/shaking. Before disabling HAGS the flight would be smooth for about 15-20 minutes, then out of nowhere the jitter/shaking. Definitely a show-stopper. I didn’t buy this rig to make myself ill. :wink:

My particulars:

Cessna 152
HP Reverb G2
Microsoft Windows 10 Home 64-bit 21H2 19044.1387
AMD Ryzen 7 4800H with Radeon Graphics - 16 GB RAM
NVIDIA GeForce GTX 1660 Ti - GeForce Game Ready Driver 496.76
Logitech Extreme 3D Pro HOTAS
MSFS GOTY Edition

Fully updated to-the-minute via Windows Update and Microsoft Store.

I’ll briefly join the whine chorus – I lost a lot of flight time over the past 3 days trouble-shooting this. I mean, I like “new” and all, but please don’t break stuff. It seems MSFS GOTY Edition broke a lot of stuff. Here’s a small list of my complaints (all VR-related – my preferred method for the flight experience):

  1. In cockpit view none of the controls/buttons on the Logitech work. Can’t release the brake. Can’t throttle up. Quite by accident I discovered that if I went to the outside-the-plane camera view, guess what? The controls/buttons work. That’s how I was able to take off and have my test flight today. It’s, like, are you kiddin’ me? This is basic functionality, and it’s broken.

  2. Similar to #1 above, in cockpit view use of the mouse is hit and miss, and mostly miss. An example – the stinkin’ “Objectives” box is right in the middle of the windshield. I hate that. So I tried what I always do, use the mouse to move the “Objectives” box to a less obtrusive location. Move the cursor over the title bar, it changes to the normal 4-way cursor, then . . . nothing. You cannot move the box. You cannot close the box. You can do nothing with the box. It just keeps sitting there obstructing your view.

  3. Similar to #2 above, if you switch to outside-the-plane camera view, then switch back to cockpit view, there is no mouse cursor to be found and no amount of banging on the trackpad or clicking left or right buttons will produce it. Again, basic functionality. And it’s broken.

  4. Similar to #'s 1, 2 and 3 above (and I have read about others having this issue), the rudder control while on the ground taxiing is totally non-functional. No steering whatsoever. Yeah, that detracts from the reality of things.

  5. So I actually own/bought the Premium Deluxe Edition when I bought the software earlier this year through the Microsoft Store. Through the Xbox software I used to be able to pick either “Standard” or “Premium Deluxe” editions to play, because apparently you get “Standard” when you buy “Premium Deluxe”. Then along comes the Game of the Year Edition. Sure, I’ll take that. Except now “Premium Deluxe” is nowhere to be found. Xbox no longer displays it. Sure, I can take that up with the Microsoft Store, and will, but, like, really?

OK, OK, enough whining for now. I’m open to suggestions on fixing any of the above. But, of course, they should not require fixing. They should just work. Period. And many of them DID work. Now they don’t. Aggravating.

1 Like

I can also confirm that disabling HAGS solves the issue. Windows 11, RTX 3070, latest drivers.

Well, I have 109.2111.23003.
I has been pushed few days ago.

That makes a lot of sense. but how do you know what point to restore the system at?

Not for me. HAGS on or off, the problem corresponds to like here.
HP Reverb G2, cockpit shaking since installing windows 11 - #105 by lucasrmdm.
I have also runtime 109.2111.23003. Ryzen 5600x, 3060Ti. Maybe windows 11 update do not switch the option correctly.

I had the sale problem in w10 too.

HAGS ON or OFF….makes no difference for me still extremely sensitive head movements in the cockpit, even my heartbeat creates a vibration in the display, crazy!

Windows 11, latest OpenXR and development tool, latest Nvidia drivers, windows updates.

1 Like

Actually it’s moot now. OpenXR did another update on the 24th that fixed my problems. The update was 109.2111.23004. If you turn Runtime Preview mode ON you will see that it uses 109.2111.23003 (yes an earlier version, for some reasonl. It is this 23003 version that works great on my system. Try it with the latest and turn Preview on.

As far as the restore point, I just used the most current one before 11/20/2021.

same here :frowning:

For me its unfortunately unplayable at the moment. The sensitivity of the glasses is far too high. A small tap on the glasses causes extreme shaking of the cockpit. :tired_face:

Hey Guys,

I just mounted a new PC yesterday, having the same BUG (Wobbling Screen in the G2).
pretty much everywhere after I launch the flight (even in the VR Room with the
floating Menu). All tricks even HAGS of or on are making no difference so far.
Screen also seems to be a little bit less sharp than usual I think.

Here the specs:
i9-12900K
RTX 3080 Ti
32 GB RAM
Games on ssd
WIN 11 (updated)
NIVIDIA Driver (updated)
OpenXR (updated)
WMR (updated)

One of the main reasons for me to build an new
PC was to be able to fly smooth in MSFS.
We need a workaround quick :unamused:

Anyone with a new idea?

I followed the suggestion in the above mentioned post on disabling HAGS in windows 11. Rebooted and the shaking is gone. Strange that it works for some and not others🤷‍♂️

To find out I think we have to share every configuration we made in the WMR Setting, OpenXR Setting
and Graphical Settings, maybe even the MSFS Settings. Most common problem on such different
outcomes is the everyone has a different mix of failures and settings.

I wonder if we’re not talking about two different issues.

  • Issue #1: shaking/jiggling of cockpit. Very sensitive to headset movement. Vibrations even occur in sync with heartbeat.
    SOLUTION: none found

  • Issue #2: Wild moving of screen objects inside and outside of the cockpit occurring suddenly after several minutes of smooth flight, making further flight impossible.
    SOLUTION: Turn off HAGS, or update to most recent OpenXR.

Have I got it right?

3 Likes

It would occur instantly as soon as I switched to VR. Slight movement and the whole screen would wobble. I disabled reprojection in openxr also and run latest preview.