I cannot load any different airport and plane - always the same airport and same aircraft - non ascii windows 10 account name

Hi @paranoidharry,
The cause of this is a non-ascii character in your Windows 10 username. Even if you have changed it - as changing it only does it symbolic.

There is a work around with what @BlondeAcrobat62 wrote or you can change Windows 10 to use the new Beta UTF-8 language set.

To do that, you have to go to “Control Panel” → “Clock and Region” → “Region” → “Administrative” Tab → “Change system regional configuration…” → and check the “Beta version: Use UTF-8 for language compatibility” checkbox.

EDIT: This post was merged from another topic.

3 Likes

But this conflicts with the following: Citation CJ4 (and apparently all other planes) not following flight plan loaded from World Map planner - #18 by WrngwyCorrigan
And there you should instead uncheck Use UTF-8 for language compatibility “checkbox”!

1 Like

Exactly.
See my post above:

Your suggestion solved this problem for me. And of course. Why have we not thought about it something before. It’s actually a children’s lesson for any programmer. But who would have thought that it was the alphabet problem that in 2021 caused problems in a microsoft program?
Incidentally, it also solved another problem for me:

Now it all works again. And my machine has become noticeably faster in performing the various processes.
Thank you very much. In my case, it was the use of “æ” that gave the problem.

Hi @Hester40MT ,

Thank yo! That solved my Problem. So i did not need to delete the temporary *.FLT file.
Thank you, too @BlondeAcrobat62 .

Best regards,

Harry

1 Like

Wow!! Thank yo! That solved my Problem. So i did not need to delete the temporary CustomFlight.FLT file.
Thank you.

Best regards,

I have a problem where I can’t change airport or airplane in World Map. It’s the same as I chose the first time I tried it. I have tried to uninstall the game and reinstall it, but it’s still the same problem.

When i search on the internet, some people say I need to delete a file names CUSTOMFLIGHT something, but I can’t find it anywhere.

Someone that maybe can help me?

With username containing (in my case Ø) non English letter:
The destination is locked to last visited.

  • Solution to this is to tick off beta box in Win Admin to read URF .

This fix creates a new bug:
Selecting a (normal length) route between Departure and Arrival - the result is far off.
Distance is always higher than 5000 nm . Desired Track is far off.
And aircraft do fly in wrong direction - not following magenta track.

I have tested this - confirmed

The enable TUF-8 solution creates a new issue — a new created flightplan is corrupted.
This is confirmed by enable/disable TUF-8 . Able to select a new destination with corrupted flightplan. - Or - Stuck at last destination with correct created flightplan.

A solution mentioned above - is to delete saved files in MISSIONS subfolder. It works - but very awkward. You have to do this prior to each flight. I tried to rename the folder, but a new one is created each time.
Now I am stuck. Maybe try to change username - Is it my ØYSTEIN PC that makes this problem? is it easy to change username?

Sorry -but I have to let out some steam.

This has been a 10 hour long extremely frustrating ride. All alone troubleshooting without serous help from moderators.
Moderators read only part of my post.
My initial post was about corrupted flight plan. Aircraft does not fly correct heading. Very detailed examples added, but not read. Solution was to check joystick deadzone and similar stuff - and post was locked.

I tried again to explain that origin of problem is the TUF-8 solution.
I tried several times to explain that the issue is the corrupted flightplan, not locked destination.
All new post was deleted with reference to this thread.

  • Now I cannot recommend fs2020 to norwegian fellow simmers with scandinavian letters in their names

Hi @OracularSheet83,
This topic is for what your problem is about. The non-ascii letter(s) in your Windows 10 account name. Read the notice at the top of this topic.

This problem effects various aspects of MSFS from flight planning, navigation, saving/reading of flight plans, etc. (Again, this is mentioned at the top of this topic)

If you read posts above in this topic, as I pointed out to you in a private message, you will see that changing the account name in Windows, will NOT correct the problem. Changing only makes a visible display change, not a programmatic change.

The only way to correct it at this time, is to create a NEW user account on your PC that does not have any non-ascii characters.

Again, file a Zendesk ticket on this so that the developers can fix this as what was mentioned to you in the private message I sent and is also mentioned in this topic.

Here is the link to Zendesk:
https://flightsimulator.zendesk.com/hc/en-us/requests/new

Thank you Hester for quick reply -appreciate it!

This thread is 87 long - and cannot pinpoint exactly my problem with corrupted flightplan with TUF-8 enabled. Hope this example will help

Example:
Case 1 with TUF- 8 enabled.
Creating a simple short route on the "planet: (Selecting Destination and Arrival)
Course south - Distance 13 nm

In cockpit the GPS reads;
Magenta track is correct
Desired track : 064
Distance 67331.1.
Start flying - Leg time is 49 hours - Arcraft do fly heading 064…

Case 2 - with TUF-8 disabled.
Identical route created. Distance 13 nm . Heading south.
In cockpit everything is correct.
Desired Track is 180
Distance 13 nm.
Start flying - Aircraft flies correct . Heading south - following magenta track.

This issue is confirmed by testing at least 10 times with TUF-8 enabled/disabled with different routes created.

I tried a different walkaround with deleting saved files in MISSIONS subfolder. It works, but it is really awkward to delete files each time you want to change airport. I tried to rename the folder - but a new one is created.

Zendesk is contacted. Hope they can help.

At this point, this all you can do until the developers look into this.

Zendesk is mostly bug reporting. If they do respond it will most likely be to create a new user account on your PC, as currently, they do not have a fix for this.

Several months ago, they did correct non-ascii but a small few still have the problem with certain characters. This topic only has 18 votes at time I write this, so not many have the problem - or users are not up voting this topic or they are not submitting the bug to zendesk. This is why we do not like duplicate topics - it hurts votes. If the developers don’t know, they can’t fix it.

1 Like

Again - thank you for extremely quick response.
And I see your point of spreading same topic in several threads.

If a bug fix is depend on number of votes , this issue is doomed.
A qualified is that number of users with ÆØÅ letters are 0.000001 % of total. And most of them are Xbox gamers that have already moved on to next game.

I will warn Scandinavian FB flightsim groups about this.
You may be stuck with only one aircraft that works - the Carenado Mooney with Garmin GN530 mod added.
Yes - it is worth it - but do not delete your current simulator .

Now I am fed up being a beta tester . Signing off for now and do something fun - do some cross country flights in the Carenado Mooney

Lucky - I was invited to file a bug report. -Done

For me , personally , a minor issue.
As a serious simmer , I plan the route from scratch in the Garmin530 (the 530 mod is recommended) with no issues.
With SkyVwctor and Approach plates, creating and flying the route is very realistic and immersive.

About CUSTOMFLIGHT
When I start a first flight, the software creates a set of 4 files named CUSTOMFLIGHT (.FLT,. FLT.FSSAVE, .PLN and .SPB) in the CustomFlight folder
C: \ Users \ xxxx \ AppData \ Local \ Packages \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ LocalState \ MISSIONS \ Custom \ CustomFlight.
Then each time I want to start a new flight it is always the same flight (CUSTOMFLIGHT) which is launched!
If I want to avoid this I have to

  • delete CUSTOMFLIGHT files
  • or to save and then reload the new flight but I no longer have access to the Weather forecast in flight.
    Why does the software keep the first flight and not delete it?
    How to avoid this?

The flight is saved automatically at the start of each flight to provide the user the ability to restart their flight any time during the flight or when their flight has finished. There isn’t any way to avoid this feature.

The problem that everyone is having is that if the user doesn’t want to restart the flight, the files are not deleted and interfere whenever a user created saved flight is restarted.

Thank you for your explanation.
I understand the reason for saving so that we can restart a flight.
The problem I am having is that if we save another flight, under another name and in a different location, when running the FLT it is not possible to change the weather.
But I fixed the problem by deleting the CustomFlight file.
It would be better if the software offered erasure when you have finished a flight and come back to the main menu.

Hi @franchimoise,
See my post above as to why this is happening:
https://forums.flightsimulator.com/t/i-cannot-load-any-different-airport-and-plane-always-the-same-airport-and-same-aircraft-non-ascii-windows-10-account-name/302113/87

Currently there’s 3 work arounds (one of them I would not suggest).

  1. Create a new user account on your PC that does not have any non-ascii chars
  2. You will have to manually delete those 3 files every time you use MSFS
  3. NOT RECOMENDED: This does work but will cause other issues
    See this post:
    https://forums.flightsimulator.com/t/i-cannot-load-any-different-airport-and-plane-always-the-same-airport-and-same-aircraft-non-ascii-windows-10-account-name/302113/78?u=hester40mt
    And this post:
    https://forums.flightsimulator.com/t/i-cannot-load-any-different-airport-and-plane-always-the-same-airport-and-same-aircraft-non-ascii-windows-10-account-name/302113/79?u=hester40mt
1 Like

Hi Hester40MT
Thank you for your answer.
After a lot of research I found solution 2 on my own.
I had found another solution which was to save the new flight with a name in a personal folder and to reload the FLT file before starting the flight.
But with this solution I lost the possibility of modifying the weather forecast during the flight.
Now that I know the origin of the bug I no longer ask myself any questions and I systematically erase the CustomFlight folder before each new flight.
… Until Microsoft or Zendesk takes into account the report of the bug!
Sorry if my English is not perfect. I am French and I use Goggle translator to correspond.

I fix mine as the following:

1st: In-Game: Turn Bing maps off in Options->Data. It will disable the Bing Map and enabling the loading of the game.

2nd: If your Windows system setting is coded with non-English language, it will cause the glitch. **You will need to change your system’s non-unicode setting to English.

PS: I still experiencing CTD during some flights, but not every flight, very randomly.