I cannot log into DevSupport anymore. Login Loop Error


:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes, I am a Developer and using Developer Mode, stock Vanilla MSFS

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

This is non related to that.

Brief description of the issue:

I go to log into the Developer.flightsimulator.com website and I click Login and a blip occurs of something that appears and then disappears. Then a pops up saying my account is being processed for activation. This has been like this for well over a week. Perhaps longer. I have re-logged into my XBox account many times. That does nothing. I have no way to create a ‘forgot login’ to request a new login email.

What do I do? I cant get into the Developer forum. :frowning:

Kind regards,


Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Go to Developer.flightsimulator.com website and click ‘Login’

PC specs and/or peripheral set up if relevant:

PC, Windows 10

Build Version # when you first started experiencing this issue:

about 2 to 3 weeks ago, approximately.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

The website you linked doesn’t work, try https://devsupport.flightsimulator.com/ as you maybe logging onto the wrong website.

Also, see: Why can't I log in/create a forum account? Troubleshooting

In addition, make sure you have pop ups enabled temporarily as it will redirect you to the Xbox login website

I tried your link, just in case. Same link as mine. Same result as well. It says the verification is in progress.

Do they send you an email? I looked through my Spam folder to see if something was sent that I missed. Nothing found.


When I signed up it was back when they didn’t use Xbox Live accounts. Did you have an account before, or is this the first time using DevSupport?

Also, does it redirect you to the Xbox Live login?

I had it before, it quit working perhaps 3 weeks ago. They were just starting to move it.

Yes, it refers me to sign up and ask for lost password, and also says to sign in with XBox Live, which I do not find a XBox Live… Only usual main XBox app and XBox Insider.

If I log out of XBox, then try to log into Devsupport, it doesnt work. If I log back into XBox, it does the same thing. But it says my account is waiting for ‘activation’. I was told they send you an email. But none have come in.

Does anyone know who to contact concerning not being able to log into Developer.flightsimulator.com?


Hi @LyonHaart001

I asked at the DevSupport forum to see who could help you :slight_smile: User can not sign into Forum using XLMS - Site Feedback - MSFS DevSupport

1 Like

Many thanks, @HamMan2118
Massively appreciated.

Perhaps if they could re-send the email that supposedly they send out, I can go from there.


1 Like

Someone suggested clearing your cookies, have you tried that? :slight_smile:

1 Like

I did, about 45 minutes ago. Didnt work. I logged into XBox Live as well. Didnt work. Right after clearing data, I tried logging into DevSupport… and it does the exact same thing, like a loop. No way to request a new password, only that my account is waiting activation, to log in with XBox Live, etc. I click it and it disappears and pops right back up again.

1 Like

Thanks for being a middle man on this for me. I very much appreciate it. Thanks for your help.

1 Like

Hey @LyonHaart001 Try doing what they say here:
User can not sign into Forum using XLMS - #5 by cdgonzalezgo - Site Feedback - MSFS DevSupport :cowboy_hat_face:

There is also this you can try as well-User can not sign into Forum using XLMS - #6 by Boris - Site Feedback - MSFS DevSupport

@HamMan2118 ,

Can you tell Boris, my handle is LyonHaart001 and my first three letters of email are soc

Many thanks Sir.

Done! :slight_smile: User can not sign into Forum using XLMS - #7 by HamMan2118 - Site Feedback - MSFS DevSupport

Hey @LyonHaart001!

Good news, your account is activated! You should be able to log in now :partying_face:

1 Like

You are awesome. God bless you, HamMan2118!

I just checked, logged in fine.



1 Like

That’s awesome!! Happy to hear :saluting_face:

Just chiming in here to say all of our NZA Simulations accounts cant log in either. Have tried all sorts of things but are currently locked out of devsupport.

Stuck in a login loop. To replicate you click on the login button and it presents a new user registration. you then try to click the ‘login with xbox live’ and it loops.

I’ve even tried to pre-login within the same browser into xbox live and trying to click the login into xbox button.

Hey @HybridNZ :slight_smile:

I’ve asked on the Devsupport forum. Will get back to you in a bit :smiley: Did you already have a registered account on there?