I can't start MSFS - Gaming Services keep opening


Out of the blue, I can’t start MSFS from the Game Pass. It opens Gaming Services even when it’s already installed. I uninstalled Gaming Services, reinstalled, added exceptions through powershell and disabled Firewall… Still same issue.
I’m lost… Thanks for your help

Hi @tchitkom,
The team is looking at Gaming Services for some issues. What version is installed on your device?

Also a double-check on your Windows 10 network connection - is it setup as “Public” or “Private”?

I can’t find the version number. I’m on a private network…

In MS Store, there should be a most recently installed app list, however, that doesn’t keep an entire history.

You can also go to the Task Manager under “Services” (or type "services in the Windows 10 search) and see what version “Gaming Services” you have and if it’s running.

Also in “Services”, see if any xbox services are running while MSFS is running. When MSFS isn’t running, those would be “not running” (they get auto turned on).

So I have the version 10.0.19041.6165 and my Windows 10 is fully up to date.
Edit: 2.51.3002.0

Did you happen to notice if those services were running (gaming services and any Xbox related services) while MSFS is running? I believe “gaming services” always runs even though an Xbox game (MSFS) isn’t running.

I didnt know the existence of Gaming Services before it started playing out like this. If I look at Services it’s running. I can’t start MSFS though…

Try this as a test:
Go into “Services” from Windows 10 search. Look at for any Xbox related services. Make a note if they are set to Manual, Manual Triggered or Automatic (so you can change that back if this test doesn’t work).

After making a note of that, manually “Start” all those services. Then try to launch MSFS.

Here is what mine looks like:

Normally, these should turn on when an Xbox game is launched.

I gave up and I am currently reinstalling MSFS. Will check this tip if i still have issues…

I have a strong feeling that reinstalling MSFS may not work as it’s more related to Windows services than MSFS.

Reply back if it did work! I’ve been wrong before! :slight_smile:

For what it’s worth, reinstall did fix it…

1 Like

Closing topic as issue solved by OP.