I got some weird texture gltiches

does anybody have a similar problem or knows how to solve this?
I tried a lot of different things, but nothing worked out for me.
My only Addon right now is the Headwind A330-900neo.
I couldn’t find anything similar in the forums or on the internet.

My PC Specs:
GPU: Strix Vega 56
CPU: Ryzen 5 2600x
Driver: Radeon 22.2.3

Maybe try the recommended AMD drivers instead of the optional beta ones.

Its worth a try. I never had problems with the AMD driver

Can you run other demanding games and benchmarks without problems?

other Games work perfectly fine

Have seen this before on nVidia and they needed to release a new driver for it. So def check your drivers


I downgraded my driver and restarted my pc but unfortunately it didn’t help.

Try clearing all caches.

Also see this topic:

thank you, it seems to be a bigger problem.
I already tried dx12 today… no texture bugs, but a really horrible performance.

Which drivers did you go back to?
This may help

A couple people in the above topic said that Radeon-Software-Adrenalin-2020-21.4.1-Win10-64Bit-Apr20 may have helped.

Unfortunately this looks like an AMD driver bug. Nvidia also had similar issues but already fixed it in their drivers.

You could submit this issue to Zendesk and see what they have to say about it:

i tested different Versions. The latest was 21.10.2.
now I’m checking 21.4.1

Back to basics.
Remove all community folder mods and test

Delete Rolling cache and restart msfs no mods, test.

Asobo seems to have made some changes to the renderer that caused these tiling issues to manifest themselves in recent drivers from both AMD and NVIDIA.

I have never seen such a buggy game. Completely without mods, it currently runs slightly better.

Moved to #self-service:install-performance-graphics

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.