IFR flight issues (G1000)

yeah understand that from video. Will make test in a while to check this functionality. On other side, expect now this (much real feature) inside FS2020 G1000 is very prematurely in my opinion. In G1000 are missing also some basic options. Ok, I’ll make tests.

I think you are right, and I fear the G1000 is missing a lot of these features for the time being. It would however be nice to know what is missing and what is implemented as I’m currently stuck wondering if I’m doing something wrong or if the sim is doing something wrong :sweat_smile:

Did quick test on LZIB rwy22 with C172 (G1000) and all 3 app types GPS/ILS/RNAV rwy22 and all working perfectly with 3 different color ball/brick glide indication (white - GPS, green - ILS, magenta - RNAV). Yes I can confirm now that automatic set CDI to LOC isn’t aplicable. Question is if it is really needed because in this case I can change also CDI to GPS app used ILS22 points for nav. I see this system as enough for me, manually set CDI to type what I require with selected NAV1 ILS freq. All is working perfectly and also distances are very precise to my tests now with Jepp charts DME.

Also as another knowledge I link this topic, look what people says without to know what their aircarft can do:

Just my opinion,

simply to me is this Sim perfect also for IFR (in this time what airplanes offer in case of not other bugs inside Gs) with also visual page, completelly. Really don’t understand opinions that this isn’t possible. First what we really need is know our aircraft and it’s possibilities.

The known issues page just got updated with this bug added, so at least they will fix it :slight_smile: I do wonder about that NAV1 frequency though, did that set itself for you automatically when you select the approach procedure on the G1000, or do you have to manually enter the correct frequency? Not a huge deal to work around, but still a bug worth reporting :slight_smile:

" Garmin avionics issues:

  • Some airliners core systems are partially or not implemented
  • The switch from NAV mode to LOC does not happen automatically"
1 Like

Yes, I need set it manually.

Thanks :slight_smile: I will try to follow my normal procedures, except setting the NAV1 manually, and switching the CDI manually to the right source. Can survive that as a work-around for a while until Asobo get around to fixing the G1000.

1 Like

Also thnx to you with constructive talk, apreciated…

2 Likes

From the AUGUST 20TH, 2020 DEVELOPMENT UPDATE @ https://bit.ly/3lbZnlR

For complex aircraft, WebAssembly is still undergoing active development. We are working on some much-needed features and providing code to help port existing C++ aircraft. In addition to this, we are also actively working on mapping out the functionality of the SimConnect API. We look forward to your continued feedback, which has proven to be invaluable so far!

Things are looking good for more complex aircraft systems and GPS functionality, which is where WASM modules come in. I’m somewhat of a gauge programming fan from the FSX era and looking forward to more documentation and demos in this SDK area. Things are a bit sparse and complicated at the moment and documentation on the fundamentals of the framework we’re in when programming gauges would be helpful.

I’m also a web development student and have been reading up on all things WASM (web assembly) related both in Javascript and ASP.NET Core. It’s a fascinating technology.

1 Like

I think the future is bright for this sim :slight_smile: It would be good if the devs had been a bit clearer on what does / does not work on the various systems. It was quite frustrating flying around expecting the G1000 to work as it should only to discover that VNAV was entirely missing and the approach procedures are somewhat crippled (although that can be worked around as described by Omico).

2 Likes

This functionality issue should really should not have been the case at release. I don’t recall any issues with ILS functionality in FSX or VNAV at launch. Then again that was 13 years ago :wink:

I rarely use VNAV in real life, so I haven’t really played with that. I did manage to do a successful ILS approach, though as mentioned by others I needed to input the nav frequencies and switch the CDI manually. That approach also had an IAF that was a hold which the G1000 was therefore unable to add to the flight plan. Fortunately, since this was an ILS approach, I was able to navigate to the IAF using the localizer and DME, the old fashioned way. Kind of defeats the point of using a G1000, but at least it worked. It’s RNAV approaches that are almost completely unflyable.

Everyone who’s posted on this thread should also make sure to file requests on Zendesk so the team can properly prioritize these issues.

I have also found there is no vertical guidance on RNAV approaches in the TBM 930 G3000.

Hi Fam!

Just wanted to take a min to post a Link to a Good Play list for the G1000 Expected behavior. I’m not sure if the Devs are monitoring this Thread but it would be good to take a watch. As always, every Aircraft is different so i think a Garmin Rep would know most about the per plane systems here. I posted these video in another thread but this looks to be the G1000 Mega Gripe Thread =)

If you are interested in official G1000 PCTrainer Direct from Garmin (For a Fee) see below: https://www.garmin.com/en-US/search/?query=PCTrainer

1 Like

Yes, the default G1000 on X-plane, while not perfect, is light years ahead in terms of functionality to the one in MSFS 2020.

1 Like

Hello and thank you very much for your detailed reply, perhaps you can try this simple ILS approach and let me know if you have the same issues, it may be my equipment: The following is a very short flight out and back to the same airport using an ILS approach.

  1. Once the simulator loads, select World Map
  2. Select Cessna 172 Skyhawk G1000 as the airplane
  3. Set Departure Airport to KVNY / Runway 34L and “Departures Direct” and Arrival Airport to KVNY with “Arrivals Direct” and “Approach ILS 16R-Y” (KVNY is Van Nuys GA airport 25 miles N of LAX just so you can get your bearings.)
  4. Selected IFR Low Altitude Airways
  5. (You should now see the flight plan as “KVNY – ZIDOM – UMBER – JINAT – FURRY – KVNY)
  6. Begin the flight but before take-off set the following on the PFD: (This is not exactly what to do in a real flight but it will make the test a lot easier for you)
    a. Select a cockpit view that gives you full access to all the controls on the PFD
    b. Click “FPL” to confirm the flight plan is loaded
    c. Set NAV 1 to “111.3” for the ILS 16R frequency
    d. Set ALT to 6000
    e. After take-off, click the “PROC” and select “Activate the Approach”
    f. Then click “AP” to turn on the Auto Pilot and “NAV” to navigate to the first way-point, ZIDOM. (If you want you can also click on the “VS” and set “Nose Up” to about 500fpm just so you can clear the mountains more quickly)
    g. Don’t bother with ATC at this point, it is just a test of the flight planning system
  7. It takes about 10 minutes to get to ZIDOM, one thing I noticed is that in the header of the PDF it displays “GPS AP”, when it should display “Active Flight Plan” ???
  8. Once you make the turn at ZIDOM, the flight plan will display “ZIDOM to UMBER” which is correct, but suppose you want to go direct to JINAT instead, here is what I tried:
    a. FYI: DO NOT PRESS PAUSE to try this and then pause again to return to flight mode, my plane goes into a spin as soon as you release the pause, but that is a different problem.
    b. Press the “FMS” knob to get a blinking cursor and scroll to JINAT and press “Direct To” - This is supposed to bring up JINAT so it can be selected and then activated so the plane can navigate to JINAT. BUT the screen does not display any way-point, so unless you want to enter it all manually, you can’t change course.
    c. I also tried selecting UMBER and pressing “CLR” to see if it would remove it and go to the next way-point (JINAT) but it didn’t, but then neither does the real G1000, but at least in the real G1000 you can delete a way-point and go direct to any other.
    d. There is also no option for “Vectors to Final”, it is there on the screen, but it is not selectable.

So in the end, I can’t delete a way-point or fly “Direct To” a different way-point or opt for “Vectors to Final” within a flight plan, so that’s why I think this needs to be corrected if this simulator is ever going to approach a sense of real world navigation.

I am very interested to hear back from you to see if you were able to complete the flight with better results. Thanks…

1 Like

After reading every freaking post in this thread, the conclusion is obvious- and DarrenEvans007 said it right at the start. The developers were more interested in getting the amazing eye candy state of the art graphics out to a wider audience than satisfying the long-time MSFS simmers who had a right to expect that things that were not problems in FSX or FS9 be problems now.
Autopilot glitches? ILS/VOR frequencies not listed on the map? Vectoring to incorrect waypoints? etc. etc. etc. I mean, this sim was tested for months by LOTS of people. How did they miss this??

With past MSFS versions, even if you weren’t an expert trained pilot (I’m not) you could at least use the autopilot fairly well. Even 16 year old FS9- all major systems, except for minor bugs, worked on day one. Sorry guys who think this is OK…it’s not.

2 Likes

No doubt, there is an unacceptable amount of bugs with the navigation systems, which are a large part of simming for most serious simmers (by that I mean people who wish to fly accurately according to procedures and ATC instructions). We should all just report bugs as we find them, and hope that MSFS show a willingness to correct the bugs and add the missing features (VNAV!). They appear to be on the case, so I believe they will sort it out sooner or later :slight_smile:

3 Likes

the G1000 is a really bad implementation compared to the real thing! many features just not working. In the first 5 min: no Backup mode, no Engine - System - Fuel page. And the flightplan page I dont want even start … really disappointed here!

2 Likes