I'm now getting freezing after about 15-30 mins of flight 99% of the time. (Clean community folder)

Please tag your post with #pc and/or #xbox.
A. PC, running Windows 11.

Are you on Steam or Microsoft Store version?
A. Microsoft Store

Are you using Developer Mode or made changes in it?`
A. No changes (Clean community folder)

Brief description of the issue:
A. I’m getting CTD After about 15-30 mins of flight 99% of the time. The sim will just freeze up and I’m
forced Ctrl-Alt-Delete to shutdown,

PC specs and/or peripheral set up of relevant:
Windows 11
i7-8700k @ 5.00 GHz
RTX 2080 ti
32 G ram
spad.next, and TrackIR.

Build Version # when you first started experiencing this issue:
A. SU # 7 (

I got my first CTD after upgrading to Windows 11. Never had any problems on Win10. After SU7 it got really worse. If I enter slew mode and “fly” around for 1 minute or 2, I also get a crash. Tried various things: Switched off overclocking for cpu, gpu & ram. Reinstalled msfs overnight, changed graphics settings, removed 3rd party content… Still the same. Fault code always 0xc0000005.

Thinking about reinstalling windows, but windows 10, because I got my first ctd on win11. But it’s always so much work to install everything again… Will follow this topic.

1 Like

5.00 GHz? … I think I might see your problem

1 Like

Freeze up, or crash to desktop? The difference is important.

If the sim hangs, are you using the middle mouse button to freelook toggle, and perhaps pressing up on your yokes hat switch? Big assumptions here, I confess, but still.

1 Like

My i7 is very stable at 5 GHz.

1 Like

Good point.
most of the time the sim will hang and become unresponsive. I guess that’s technically not a CTD.

Very interesting point about the hat switch.
The sim did hang after pressing up on my joystick hat switch…
I’m gonna try to reproduce it after I get off work tomorrow morning.

1 Like

It’s interesting all this started happening after SU7, before this the sim ran beautifully.
I crash today while using my hat switch to look around the cockpit but it’s hard to say if that is what triggered it. the sim will also freeze up if it’s just sitting there as well.
I’ve tried various things as well nothing seems to fix it.
I get no error message, just a lock up.

1 Like

All - Try this, will not guarantee it works. I think but cannot absolutely prove, SU7, caused some files to become corrupted in the game, not enough to stop it, but to cause some of your problems.

At administrator command prompt - run these two commands - if nothing else will find and repair any files in any directories/programs corrupted MSFS too.

  1. SFC_/scannow – it could take a while
  2. Chkdsk_/F/R - This one will take a while. It may want to run next restart choose Y, restart PC, this program will run after POST but before OS loads.

Then test game again, and see if this works. I as a rule never get CTD’s, but one updated file in Content manager with SU7 constantly caused game termination, so after I did above, then was able to get CM updates, and no more setting resets. And you aint got nothing too lose.

1 Like

I will give this a shot tomorrow and report back, Thanks for the info.

This is interesting. I am having trouble with the sim freezing up. It randomly freezes. But when it freezes up, the sound still continues until I have to use the task bar to “end process” for it all. I am using the hat alot on the bravo quantrant flight yoke. It has only started doing this from the lastest update… I wondered if I actually caused the fault because I didn’t do any back up prior to the update.

It drives me crazy trying to work out how to fix this issue. I am using the mouse and hat to swivel the hat around from side to side. I use the mouse to postion the look placement. Sometimes It can freeze straight away and other times I get a reasonable flight time, then it crashes. I really don’t know if this is related to your issue. But when I fly now I will take note of the mouse position. I will report back.

I am thinking of doing a clean install. As I have also somehow stuffed up the community folder.

1 Like

Don’t clean install. Just double check that you aren’t hanging because you have pressed the middle mouse button then the hat up switch, or whatever you have bound to Next Pilot Position.

It’s a 30 second test. Spawn in, press middle mouse button, press hat up. If it hangs you found the cause.

1 Like

Thank you so much. I changed the binding and does appear to be ok at this time. I have had this crash quite a few times and at random times. Even when I am flying around and not touching anything. I am hoping this is the fix. I started getting the toobox out and was going to check under the hood.

I am hopeful . I will check back in if the problem arises again. Muchly appreciated.
By changing the setting on the HAT seems to have work without crashing. How did you work that one out hobanagerik?


I’m having a similar issue. Ever since SU7, game freezes 15-30 min into every flight. Doesn’t matter the aircraft or location. The game never fails to freeze at some point. It’s not exactly a CTD, but the result is the same. The game just suddenly freezes frame, audio continues to play, and the only way out is to go to task manager and force end process the game. I have a hunch that this could have to do with USB devices disconnecting momentarily, but I’m not 100% sure. The reason I say this is, since SU7, the bug where unplugging or plugging in a USB device crashes the game has returned for me.


This is my experience exactly.

I tried it today. Unfortunately it’s still unstable and crashes me to desktop. Thanks for the tip tho!

Could you guys with the same freezing /ctd problem try something out?

Spawn on a runway with the default a320 (e.g. eddm)
Enter slew mode (y)
Warp up to about 2000 ft (F4 I guess)
In slew mode, start flying forward, a bit right, a bit left, turn a bit while flying forward for a minute or 2 (num pad 8, 4, 6, 3)
In this scenario I get the same freezing OR ctd as in a normal flight, sometimes after 10 seconds, sometimes after 1 minute. So for me I think it’s a (scenery) loading problem. Happens with every aircraft, on a fresh install, even when overclocking is turned off.

Today, on a normal flight, it ctd’d me after about 30 minutes on crz level, always with the same error code 0x000(…)5

Really strange behaviour.

Last evening 10PM EST USA, was flying DC Designs F-14B from KDAL to KLTS, and periodically the sim would freeze for second, then the azure servers went out. Finally turned off ATC and flew flight without them, had to find transponder, did not get it soon enough, they cancelled my IFR, but flew it anyway. I cannot say if the stutters/freezes are my slow Internet which seems to be getting worse, or the game. Maybe try another flight from KLTS back to KMGE which is home base of my bird.

All ensure content manager files are all up to date, and I would clear community folder before I checked them and allowed download of any. I know they were all updated, but went back in few days later, and couple need something else, so As/MS is updating things and not letting folks know. Based on above, that won’t fix it, but may alleviate it some. Then add in CF folders one at time to see if something 'Not updated" in one of those is throwing off MSFS with SU7. And now I need to do that as well, as I just thought of this. There are new updates for honeycomb devices and a new version of the GTM-750 Nav program. I think I have 5 things in CF. There is an updated file for the DC Designs F-14, but the .0.2 is the same, they fixed one file and just let number stay same. It fixes HUD issue. So, it makes no difference where flight is, sometimes it does and sometimes it does not. Have NOT tested any native planes in MSFS, i.e., 747 and the like, as it seems to affect all.

On Series X and this is the most unstable version since Xbox release. Between CTD, freezing and Mouse cursor disappearing the SIM is unusable in this state. I even uninstalled and reinstalled everything. It is Problem after problem now. I don’t even try to take a real fight anymore because it will just be time wasted.

I´m getting the same problem. The simulator freezes after changing the pilot view using the mouse and then pressing up the hat switch on yoke to get to next pilot position.

1 Like

The SFC found some errors on my system and they were fixed on the next reboot. MSFS update 7 hasn’t CTD’d since. Thanks

I’m sad to hear others are still having issues. I wonder how long it will be before have a stable flight simulator from microsoft. 15 months and counting…