Incredible slow (initial) startup

Yes, of course I have. Seemed common practice, so was the first thing I tried.

Just confirming. Your post here didn’t say that you had tried rebooting, and that solved the same issue for me, so I wanted to make sure you didn’t forget to do that.

MSFS Team

Nope. Thanks for the tip though. I’ll post my findings later on when the sim has re-downloaded. Will start it without any mods or extra content from marketplace to make sure nothing but the ‘plain’ version is started.

Update…re-downloaded the sims, so only the basic content and nothing in community folder… Still very slow to startup :frowning:

definitely a bit sluggish for me on start up. But its also trying to load big inhale:

The Base game + Premium/Prem Deluxe content)
FSRealistic
FSUIPC
20gb+ of Liveries from AIG
All the World Updates (sans Canada) and additional free content
3 payware airports

Out of a 500gb NVME i’m down to under 200gb free. MS is chonky af.

So… I reinstalled windows11 on my (old) SATA SSD I had lying around. Took about an hour, then reinstalled MSFS and had it find the files I had on my “gaming” M.2 SSD. The sims starts up in about 2min30sec, and from what I could test is quite a bit smoother too when it comes to fps and especially stutters. This is on the latest win11 version btw!

Will need to do a bit more testing, so now I can boot between my ‘old’ windows11 version and the new one (which is on a pretty small, slow SSD).

Gonna boot into my old setup now just to compare. That one is still on the old win11 version (H21 I think)

edit: just tried it on my previous win11 installation. takes WAY too long. so definitely something that got broken in my windows setup. Guess I’ll need to reinstall win11 over my old M.2 ssd installation now.

I’d recommend checking your Windows event log for anything out of the ordinary. Something not right is going on!

Yeah I know, it’s not like I’m a computer-noob so went step by step. Event viewer shows nothing out of the ordinary tbh. Of course, my “old” windows11 has a bit more stuff installed but even then would not explain why my MSFS just seems to lock-up when loading for several mins.

Guess I nice clean win11 install will do.

Personal Comments & Observations

Anyone on Windows 11?

1 Like

Tbh I didn’t notice a drop however I have a lot of the diagnostics disabled until I actually need them.

This exact issue has led me to research X-Plane. Loving it so far.

I’ve been on Windows 11 for months, so have got used to it’s FS performance, and I would have to say I have noticed no change after the update. No help to people with issues but just adding to discussion… it’s not across the board.

Here’s one slow startup cause I solved on PC (still not acknowledged or fixed by Asosbo though) Stopped OVRSevice causes MSFS loading to hang for 3 minutes

The only way I found to determine the cause of this loading issue is to use Windows Process Monitor to trace what is going on. It takes a bit of patience, it’s a detective game but eventually you should be able to narrow down what could be blocking the loading.

I have no issues with Windows 11 with any games, including MSFS.

1 Like

Reset your data defaults, then turn OFF rolling cache

Thx but did try that. Problem seeminglyy has been solved btw, I just reinstalled windows11 and it has been pretty smooth so far.

Should’ve not posted, karma…loading times are ok, but it’s back to a stuttering mess :frowning: Only thing I did was install FlyByWire and the simbridge tool to use FSLTL. Uninstalled them but stutters remain. Oh well, it was smooth for 2 days…

This was the answer for my problems with very long loading times. Anyone who has an Oculus Quest should check their OVRservice is running (should be running not stopped)

1 Like

I can also confirm that having Oculus installed but stopping OVRService messes with the game. With it running the main menu loads in about 50 seconds. If the service is stopped the game loads and then at 50 seconds all activity in task manager goes down to 0 and the loading screen is stuck for about 6 minutes.

This has caused issues for me in Phasmophobia as well. Definitely an annoying bug, since I’ve stopped that service because it occasionally prevents Windows from shutting down for me.

2 Likes

Thank you very much, Your answer must be pinned to the top,
I started OVRService and sim loads so fast.
No more long loading wait times.
Hats off to you. Cheers…

The stopped OVRService causing long load times has been fixed now. Thanks Asobo!