Infinite loading screen

Hello everyone,

So after the last update I started having this problem.
when I try to load into an airport I can never get passed the loading screen after I chose my plane and airport.
I have windows up to date, game files integrity was verified (I got the sim on steam), everything in the MS store is up to date, uninstalled and reinstalled the sim, uninstalled and deleted all the files manually and reinstalled the sim again.

After all this I’m still having the same problem.

does anyone have a solution to this problem?

Thank you for your help.

does it still happen if you disable online functionality? I have a similar issue that the sim just freezes on the loading screen if I have it enabled

I am also having this same issue, I was just about to post a topic. I have tried everything that you have and still the same problem, I do not have online functionality enabled.

Is this happening with ALL airports?
Which aircraft are you trying to fly?

I have this issue with Heathrow, but not with Entebbe for example

Thank you for your help,
Unfortunately that didn’t help.
I’m still having the same issue.

I am also having this problem and I’ve tried numerous possible fixes. Any plane I choose, at any airport, from runway or parking, gets me to the loading screen which hangs and never finishes. I’ve waited up to a half an hour. All content updated, all mods removed, Simconnect removed.

I’ve tried it with the stock aircraft and addons.
I’ve tried it with a few different airports and still no luck.

I’m having the exact same issue since the July 27th download and July 30th Hotfix

Do you have a tree mod installed?
I had Bijan’s season mod (older version), and it caused this issue for me. After I removed it, the problem was gone. Haven’t tried the new version yet.

I will remove it now and try it, hope it will work.

Archer371 and SwampCamel7887 I did a fresh install yesterday and got the hotfix this morning. Just removed Bijan’s mod and still had the load hang. I am just trying again because I also installed the runway mod so will remove that as well. Are Microsoft killing these? I hope not as they are paid for through the catalog. Grrrr

1 Like

I was able to solve this on my end by uninstalling every add on in the content manager that was not developed by either ASOBO or Microsoft. I have about 20 add-ons/mods from various other developers so I’m not sure if it’s isolated to 1 in particular but can confirm that at least the new WT G1000 mod within the marketplace is not the culprit. It’s the only one I’ve tried installing back in so far and was able to load up a flight with no issues. Only problem is the screen display is very dark so I deleted it from the content manager and re-activated the original WT G1000 within my add on linker to check compatibility and it seems to be working.

Okay - progress! Removed Enhanced Airport Graphics by Zinertek as well as the tree mod and have made it to a plane to fly. Have odd magenta airfield now to resolve but looks like these mods are affecting the load


when there are issues this shoudl always be the first step, remove addons , free and paid ones.
i cant belive so many gamers do nopt know this, its pretty standard in other games.

Ahhh I’m glad you’re able to isolate which mods were messing it up! I had both of those installed but went ahead and deleted all my content manager add-ons except the ASOBO and Microsoft ones. I was than able to fully load up a flight afterwards but left me wondering which ones were causing the issue. Progress indeed! Thanks for the tip!

Just tried two full re installs, and I still have infinite loading screens after selecting an airport, so I guess I’ll just have to wait for the next patch…

Do you have any add-ons installed within your content library?

Ok so I got it to work.
My issue was with the Enhanced airport graphics mod.
All the rest are working perfectly.

Thank you all for helping and I hope what worked for me will work for others as well.

1 Like

I do not have any addons. Just the Microsoft and Asobo addons.

Tree mod was the issue for me, stupid trees, cut em down. I don’t care about global warming, carbon footprint, or oxygen production.