Initial Release: Grumman Goose G21A Redux II

Dont idle the engines :slight_smile:

Remember to use floaters next time, they are there for water landings. :wink:

-eelis-

2 Likes

It is a nice bird, thank you for the work, however, this mod does not seem to work with the VL3-915 mod: when the Goose is in my community folder, trying to fly with the VL3-915 causes CTD on loading the flight, removing the Goose, the VL3-915 works again without CTD…

About the plane itself, I enjoyed my first flight with it. I did not understand why I had only one float out (don’t even know what I did to have it out).

There seem to be a modeling issue for the normals of the 3D faces on the wings, I had such weird lighting in Blender when normals were badly set, I don’t know if it the same issue here.

1 Like

Panel above pilots head, there are switches to lower and retract the floaters.
They work separately at the time, so have to use each one in turn.
Does anyone know the keyboard shortcut?

-eelis-

This looks great! I tried to unzip it but keeps saying the Destination Path is to long. anything i can do about this?

Is that because of a bug, or because the actual plane is supposed to have the engine turn off at idle? Just making sure I know whether to change my behavior or expect a fix. :slight_smile:

[Update: got confirmation via Discord that it’s a known bug, and should be fixed in future. So this is a workaround for now, just stay slightly above idle if you want to keep motoring around after landing!]

1 Like

Shorten the destination path, something like c:\unzip\

Crashes MSFS for me on loading. looks alright files wise so a bit puzzled.

Just a note regarding CTDs: I twice got crash to desktop when loading up at ‘St. Petersburg, Florida’ POI in the air, but not at the nearby ‘Sunshine Skyway Bridge’ POI. So CTDs may occur based on location as well as other factors…

[Update: got another CTD while lowering flaps from 30 to 60 degrees while descending over St Petersburg after starting at the Sunshine Skyway Bridge. The only custom mods I have in Florida are for Kennedy Space Center, hundreds of miles away.]

[Update 2: I forgot I bought some on-sale airports yesterday, including Plant City which is a ways inland from Tampa. I might be getting close enough at St Petersburg that it’s loading something up that’s causing a bug. I’m going to try uninstalling Plant City and see if that resolves it.]

[Update 3: Ok, tried deleting Plant City and Arcadia Municipal, both in the broader Tampa Bay area. I also quit and restarted MSFS just to be sure everything was initialized right… Nope, still crashes when I load up in the air at St Petersburg.]

[Update 4: Removing my liveries, the aquilasim Kennedy Space Center scenery, and the Indiafoxtecho MB-339 to see if that helps. Now the only thing in Community folder is ozx-aircraft-goose-hd. Only Marketplace aircraft and airport mods remain, and none of the airports are in Florida where I’m flying. Marketplace aircraft include Carenado Cessna 182, Carenado Mooney M20R, and Jabiru J160/J170. Jabirus often show up at airports sitting in GA parking. Still crashes to desktop spawning in air at St Petersburg, Florida.]

[Update 5: While typing up a bug report for Zendesk, I found that if I first start the Cessna 172 classic at St Petersburg, FL and then quit to main menu and respawn in the Goose, it didn’t crash. At least this once. I don’t know what’s going on anymore. :D]

[Update 6: Same session did another CTD while lowering flaps descending just east of St Petersburg. Nothing else in my community folder. No marketplace airports in the state.]

[Update 7: found my crash report in Event Viewer and submitted my bug report to Asobo. Yay! :)]

[Update 8: CTD spawning in air at Miami as well. I’ll check back on things after the MSFS update lands later today, in case random other fixes happen to fix this. ;)]

Update 9: Mystery partially solved?! :smiley: On the Discord channel someone noticed the plane config file was set to allow the Goose to be used as AI traffic. All my crashes were in an area with several nearby airports, while my less-crashy spawns were farther away from the airports and may not have spawned AI traffic or ground parked planes yet. Editing the aircraft config file to disable this seems to have resolved my crashes, and I can now spawn at the St Petersburg Florida POI, fly north of town, and land in the bay successfully!

Obviously it shouldn’t crash the sim, but that’s a good start to track down why it’s breaking for AI traffic models, and a good workaround for now. :smiley: :smiley: :smiley: :smiley:

2 Likes

Right thanks, I`ll try that. I was using ST Martin.

1 Like

I’m starting to get to that point too with location. I tried unloading all addons and still got CTDs with just this plane loaded. So, now I’m back to all addons enabled. If I load at an airport that’s default, I seem to be able to fly out just fine. If I load at a freeware, custom, payware, bespoke airport, I get a CTD.

1 Like

Is it just me, or is the attitude indicator working reversed? Pitch up, indicator goes down to brown, pitch down and the indicator goes up blue? Otherwise really nice plane and a lot of fun.

1 Like

BUG REPORT
Issue Experienced: CTD after clicking Fly in KAVL (at any parking spot)
Expected Behaviour: Loads fine
Steps to Reproduce: I have everything set to Ultra or close, I do have traffic sliders at default. After clicking to load at KAVL, game crashes. I do not have any custom scenery at KAVL.

Couldn’t find it…? :face_with_monocle:

-eelis-

Use 7Zip
TG

“Too many users have viewed or downloaded this file recently. Please try accessing the file again later. If the file you are trying to access is particularly large or is shared with many people, it may take up to 24 hours to be able to view or download the file. If you still can’t access a file after 24 hours, contact your domain administrator.” :hot_face:

Have you considered listing it on flightsim.to??
TG

1 Like

Using an Xbox One controller (thankfully now supplemented by Logitech rudder pedals), I got almost constant controller vibration while flying the Goose. In other planes I get this only when something’s shaking badly or I’m about to stall, so it’s a bit worrying! :slight_smile:

Have this same too, had to disable vibrating.

-eelis-

2 Likes

Thank you ! Very amazing :grinning::+1:


4 Likes