Installation Issues & Bugs Megathread

Use this thread and post your problems, and try to help each other out with installing it.

Troubleshooting

[Read First] How to Contact Support
Windows Store Troubleshooting
Installation Issues with Game Pass
Slow Download Speed
How to troubleshoot Crashes & CTDs at loading screen
How to troubleshoot Crashes & CTDs during gameplay
How to report a bug

Message from support:
If you have sent a bug report to Zendesk reporting installation issues and your ticket has been marked as solved, you should have received an email from our support team with some instructions.

Please look for emails from support@flightsimulator.zendesk.com

7 Likes

UPDATE:

The team just pushed an update forward that should resolve the disc in tray check. If anyone is having this issue, can you let us know if it works for you? You may need to clear your cache by running wsreset if you had the store open when our fix rolled out.

We are aware of an issue affecting some customers using the Windows Store who are being asked to insert their game disk. The development team is investigating the cause, and working on a fix.

Please note, part of the issue may be caused by users with Xbox Game Pass changing their timezone on the Windows Store in attempt to download early.

We expect a fix will be ready soon.

17 Likes

The game itself is installed and I can open it but it tells me I need a disc to play and then I found out that I cant install the digital ownership, every time I’m trying to retry I’m just getting an error

3 Likes

Hi, welcome to the New Forums. Yeah, known bug and it is being worked.

3 Likes

Thanks for clarifying

as the title say bought the premium edtion but the game downloaded the standard edtion?

Check sim content, if allow u use premium planes is ok

Premium is an addition to the standard version. Chances are the premium assets can be added separately, almost as a DLC. I haven’t had the pleasure to get the sim yet, but I’d look out for some sort of indicator that you have more content to install. And yes, what the user above said, check if you actually have premium content first.

Do i install the digital ownership thing first before the game itself

2 Likes

The launcher gives a syntax error and will not launch on windows insider builds…Do I really have to reinstall windows completely to launch the installer?

5 Likes

Downloaded 1gb (Launcher?) file and now the game is stuck at a “Press Any Button” and just loops when a button is pressed.

2 Likes

Same issue over here. I hope Microsoft will get this fixed before release.

its seems at the moment nobody can download the premuim/deluxe contect?

5 Likes

Thank you very much for your answer, still waiting to download.

1 Like

Hello,

It has been found that the release version will not work when using windows insider build.
The error below appears

This means we are stuck, or I have to format my pc and start from fresh…
Screenshot 2020-08-17 190700|690x352

https://www.reddit.com/r/flightsim/comments/ibhnqh/im_getting_this_error_on_launching_the_sim/!

6 Likes

My game crashed during installation with 3GB left. It is now stuck on please wait. This is the gamepass version.

6 Likes

I currently have the same issue. 3GB left and its stuck

9 Likes

I got stuck at the same point. Fixed it by uninstalling, restarting my PC and trying again. Then it went past there but its taking forever to install the 90GB updates. and seems to be sticking at other points

1 Like

Just got a 499 error code

1 Like