Installation issues

Hello all, I recently purchased the sim on Steam around, maybe 4 days ago. Since then, I have attempted install it. The first time, I decided to start my computer before work and install it before I left. Much to my dismay, the launcher was stuck on decompressing the first file when I returned. I troubleshooted my RAM, windows memory diagnostic and memtest did not find any errors, my antivirus is also disabled while I install it. I deleted the affected file, and the installer got past the file just to get hung on decompressing the next file. I troubleshooted again and ran as administrator, and it advanced pretty far into the download. Now with 60 gb remaining, the install gets hung on decompressing 1.129.fspackage.003 and will not advance past this even if the file is deleted. If I delete the file, the installer reinstalls package files that are ALREADY INSTALLED, and then proceeds to hang on decompressing that file for hours. I have over 17.5 hours of “playtime”, Steam support is straight up REFUSING to give me a refund and keeps saying that, since the game was “installed.” The first message i received after opening the ticket within almost an hour was them completely disregarding what I had tried to explain to them that the installer is hung, and saying that the issue was fixed. I explained to them that the installer is hanging and I wanted a refund. They replied, basically saying that it’s out of their hands and to contact support. If anyone can help me install this, I’d like the help, because I paid 60 dollars for a broken launcher at this point.

1 Like

It sounds like you might be trying to install to a non NTFS formatted drive

I’m attempted to install to my main boot nvme which I’m assuming uses ntfs and not exfat or fat32, but I wouldn’t know how to check

I agree if it’s a bought PC it’s likely to be NTFS but to check you can right click on the start menu and select disk management. I always recommend installing the MSFS packages to a separate drive but that’s a different matter and it should not stop you installing them to C: if that’s where you want them.

PS. For your problem I suggest you reset your router by unplugging it for 10 or so seconds and if used possibly a wifi reset too. Check you have a good signal/connection.

I have tried installing it to a separate drive but I still get around 2/5ths of the way through the download just for it to get stuck on a file. PC was built, didn’t buy it.

I’ll get back to you after I check to see what format my drive is in.

All 3 of my ssd’s are ntfs. Router is working fine, internet connection works.

Anything else I know would just be stabs in the dark so all I can suggest is that you contact Zendesk, they will have seen this situation many times before and can probably put you right.

My only other thought has to do with leaving or rejoining the xbox insider hub if you were in the beta. Don’t forget to update your store apps and restart your PC before attempting to download the sim.

This link may offer some help.
It is from the “Support” tab at the top of the page.
There are other installation help articles there if this doesn’t help.

None of the fixes here fixed my issue. I will continue looking

1 Like

This is a general purpose one, start with this.

I have already looked through this one, none of those fixes worked either.

1 Like

I had troubles installing the sim on my new machine, last year. I’ve tried everything, and I was really disappointed, and about to give up, when I read that hardware monitoring software (like Aida64 in my case) could cause issues when decompressing files. After stopping the software, my sim installed without any issues. Have you software like that running?

I don’t know if iCUE or Zotac Firestorm count as hardware monitoring software, despite them showing my core temps and gpu temps, would you know?

That’s what Aida64 does as well. Just give it a try and stop it.

Did that, still not downloading. Still getting stuck on decompressing.

At this rate, I just want a refund from steam and they’re refusing to give it to me, regardless of the fact all of my hours are on the launcher.

First the order of install for Steam may be different than normal. BUT, yesterday I just reinstalled as rebuilt Laptop back to OEM specs with that load.

  1. Xbox, sign in to account-find MSFS, buy it, or if already own, click on install as it was gone from my system, so the installer was blank, and it needed to do that again.
  2. It downloads 2.6GB of stuff, and puts the icon into the start menu. Click on icon, and it will start game, syncing with servers and start to update/download itself. I have previously backed up all the local files to a SSD so once the download had gotten to 5%, I paused it, then copied all those GB’s from the SSD to the folder where the game is kept. Then opened the game, and it needed to update 2-3GB of stuff, it did that and started fine.
    Steam in my opinion is just an additional layer on top of what already is a convoluted process.

FWIW-My install/copy and download process went fine, checked for game operation and settings today, and all is good. Now just need to reinstall PMDG and DC Designs planes.

New Rudder pedals coming on Monday, and second HDD in laptop is failing, so those need to be configured and the HDD replaced. Then can get back to flying.

I don’t quite understand what you’re saying. Steam version just opens the installer.

I’ve tried reinstalling. I now get stuck on decompressing microsoft-aircraft-dhc2-1.0.2.fspackage.001 and it does not get past it even after deleting the file and letting it install it again.