Installation not recognised any more (solved)

Hello guys,
I am experiencing a strange problem with MSFS installation. I have installed it on a different drive than where my OS is located. I am using the Microsoft Store version (unfortunately). I am not using developer mode.

After more than 2 months away from the using the simulator and more than 1,5 months away from using my pc, I decided to start MSFS. Firstly I received an error “0x80070032”. Looking around I tried to run the update from Xbox app and Microsoft store app with no luck. A few hours later I try again and this time it only gives me the ability to install it from scratch. Anyone experienced anything similar?

Any idea how to solve the issue?
Any way to make Xbox identify the current installation of MSFS?


Have you seen/tried this?

Thank you for sharing the link. I think that it helped me to solve the issue.

I was able to spot the issue and how it was caused ( my fault :shushing_face: )

One point to consider is that even though the initial installation is just 1,3gb, the installer wont allow you to start the installation if you dont have enough space for the whole installation. I just moved the installation to another drive, started the setup, installed the 1.3gb and then moved the old MSFS installation to the folder that I had selected to install the new MSFS installation.
It appears that the system detected the old file and I wont have to dowload everything.