Intermittent Performance Spikes, high time in Manipulators

We would love to know if there are any specific settings/scenarios that create a consistent repro.

For the problem I have detailed in my post above :

  • switching to vr mode in menu home screen
  • entering the settings page
  • simply launching the sim

will, more often than not, completely drop the performance of the sim, headtracking, everything.

Settings and scenarios don’t have any bearing on this issue.

Tested on AMD Ryzen 5600x / RTX 3070 and 1660ti gaming laptop. Happens on both.

Only once in every 4 or 5 launches of the game does it work correctly with high fps in vr. This isn’t a ‘steps to reproduce’ bug, it’s something deeper.

For my case, something new :
With the Cessna, 1st flight with fps drop close to “MUT” (see my screenshot before in this discussion)

But with another plane (JMB), the drop of fps comes each time earlier at middle distance between LFBR and “MUT” but not close to ‘MUT’ (unlike with the cessna)
Of course, second flight is ok without fps drop (like with the cessna)
Didn’t yet tried another planes to see the difference, but something i bet is that le location where the fps drop appear seems to change with the type of plane…
Liveweather on/off and flight model modern/historic has no effect to solve my problem.

The one I gave you is as an exact scenario as you will get.

Spawn runway 30 YCBG

Something I have noted recently.

I see stutters that seem to come in waves and can occur in the middle of nowhere as well as within built up areas.

I also see sudden frame rate drops. Quite extreme in some cases… Again these can come out of nowhere.

This is happening frequently enough that I have been running HWInfo on another monitor and what I see is…

When the stutters occur it is reflected in the CPU activity. As if the threads stop. Then start again.
This can’t be thermal throttling as none of my cores gets above 40c (overkill liquid cooling.)

I’m pretty certain it’s not power delivery because this game actually taxes my CPU less than some other activities I use it for and I’m also monitoring voltages and seeing nothing worth noting there either.

Is it possible that these abrupt stops in the thread activity are caused by a bottleneck somewhere else and the CPU is waiting for something from somewhere else? Drive access? (2xPci nvme Samsung 970 drives) a network thing?

Also, I’ve got 32gb ddr4 and according to the graphs I’m watching MSFS2020 doesn’t ever really use more than 16gb…

1 Like

I’ve been seeing spikes for the last day or so, with multiple CTD this morning.

Using A320 neo, unliveried, from liverpool to berlin schonefeld, IFR, low level. ATC off, preset conditions (clear skies)

I get as far as starting the engines and confirming stability, before trying to contact ground, at which point, the ambient noise stutters and stops, before CTD.

Validating files, deleting local cache and re-establishing cache limit doesn’t seem to affect the crash.

One interesting spike is during the initial load screen. MSFS drops to not responding when the progress bar is half way through…music still plays, then restarts as if it’s found it’s thoughts again and it brings me to the splash page.

Having uninstalled, and re-installed, it’s confirmed the latest update.


Update 1300.

Have removed dev mode. Now it seems that the sim is working like a charm - pulling 40-50 fps without much issue on the card or memory.

I have freeze during initial load screen since the first version of MFS, with images (showing news, missions etc…) not entierly well displayed on screen (it makes like transparency during 10-15 seconds). But it’s only since the last update i have such long drop of fps.

With TBM plane, drop of fps is comming at the same location than the JMB but is not the same than with the Cassna (witch near MUT)

I notice that virtually all the screen shots/vids that have been posted with this issue have developer mode enabled. Could it be that simple?

Welp, I removed dev mode, and flew liverpool schonefeld and am now part way through ibiza to paris cdg. No drops, constant 40-50 FPS out of dev mode.

It might be that easy of a workaround, but it’s a bit of a pump workaround; people are obviously using dev mode to get their important data.

There are numerous ways to get that info. Dev Mode is but one.
Developer Mode was implemented as just what the name implies. A tool to be used for troubleshooting and/or developing content. It is merely a window into the SDK. We know the SDK is flawed. Pretty sure Dev Mode was never intended for general use or it would not be an option, it would be a permanent menu/hot key.
I would suggest leave it off unless using it to test something or create something, then turn it back off.

Kind of like driving with the hood open, nothing good can come out of that either.

I have been noticing this occasionally on some flights where the sim literally comes to a crawl for a few mins no matter where I fly.Looks like an issue on the GPU side where my card is literally in idle state.CPU usage barely in the 20-30s.


I have the fps drop with cessna caravan 208. Today, i had one Fps Drop near the ground. Thats all. But yesterday… with fbw dev mod alter 5-10 min every 90 sec.

Installed mods:
Tree mod
And a hand full airports
Lufthansa livery

I have the issue again with empty community

4 K high details
2080 ti
I9 9900 K
400 Mbits

Nope. Not using dev mode except when I want to see what FPS I’m at…dev mode on or off makes no difference.

Sounds very familiar. Had this a number of times since the game services update.

Yep. Same here.
From 55 fps 60% GPU usage to 15 FPS 10% GPU usage. Sometimes it recovers sometime it doesn’t.
Really random for me. Same airport/aircraft/weather sometimes I get 60 fps sometime 15. Sometimes it happens already at sim start and it doesn’t recover. GPU usage stays at 14-15% no matter what I do.
Three situations to reproduce

  1. On the ground at LIMJ gate number 2 clear weather. Onece out of two times the sim starts with basicly no GPU usage (15fps gpu at 10%)

  2. Several times about 50nm south from RTT NDB (LOWI). Hapened all three times

3 . EIDW Ater takeoff RWY 34. Heading east about 30 miles out od EIDW in the middle of the ditch.

I9 10900k
32GB Ram at 3600mhz
Ausus ROG e-gaming
Samsung Evo 970

1 Like

I have the same problem. MSI Afterburner shows my GPU usage drop to 30 % while boosting at maximum 1930 MHz, FPS drops to 15. After a while the GPU usage goes back to around 95 % and FPS back to 35-40. Then it repeats.

1 Like

RTX 2080 Super: EVERY TIME I start the sim I have low GPU usage (~30%) for around five minutes before something wakes up and I can actually use the menus and start a flight. I can see the hanger stuttering in the background and the animated menu fields aren’t smooth. If I’m lucky enough to be able to click through to the world map that is jerky too.

Finally load a flight and it’s silky smooth for hours until GPU suddenly drops to 20-30% again and I get very low but constant frame rates for up to ten minutes at a time. Temperature is never an issue, and CPU is fine, and the specific processor managing the sim is never 100% maxed for more than a split second.

What’s really annoying is it was like this until the first update fixed it, then the latest broke it again.

I’m waiting for new Nvidia drivers and hopefully they will solve the issue.

Case in point: I loaded my flight with live everything in Inverness and sat on the apron for a couple of hours with good GPU utilisation. Flew up the coast for 38 mins to Wick in strong winds no problem. About 15s from touchdown GPU dropped and low frames kick in, all during landing and taxi, and parking. Sat on the apron for 15 mins and now it’s suddenly jumped back up again.

1 Like

Yeees! Until this morning, i don’t have anymore fps drop over my region. Last night i had the problem as everybody of Xbox live down. But now, everything is ok, all my problems of fps drop have gone away.
Dev mode or not didn’t changed anything for me.
Is it possible that during a few days MSF server sent bad or corrupted data (photometry ?) to the PC that make MFS buggy with fps? And reset server after xbox live down made things good again ?

Anything is possible.