Is anyone else having stutters because of ATC?

Since the last update I have noticed that when the ATC tells me to change frequencies, the game will stutter briefly and result in a 5-10 loss in FPS. I have AI controlling my radios. I suspect it may have something to do with the CPU optimizations with the last update.

System is Intel 10700K @ 5 GHz, 32 GB RAM @ 3200, RTX-3070 at 1440P. Most in-game settings a mix of Ultra & High. I have FPS locked at 40, but unlocked I see 50-60 FPS in most areas, except at busy areas where it will drop to around 35. Rolling & Manual caches are off. V-Synch in-game is off.

I use the on-board audio on the MSI Z-490 MAG Tomahawk motherboard and I also have a USB audio device that my headphones plug into so that I can have the ATC piped to my headphones while engine sounds play through my speakers.

Any advice on this is appreciated.



There can be times where ATC interaction seems to cause an fps drop, but it’s inconsistent. I have an in-frame FPS counter running all the time, and I’ve gotten into the habit of spot-checking it as an ATC event occurs. Sometimes it does, but most times it’s been benign, especially after Patch 5 (not the latest one), so I’ve been seeing this consistently for a while now.

I keep the Riva Tuner overlay on as well, that is how I see the drops that accompany the stutters. If I turn off AI radio control and switch frequencies, it is smooth as warm butter while cruising…most of the time :smile:

Are you actually responding to the ATC interaction (i.e., clicking the response), or is AI doing it all including answering?

I’m wondering if there might be a difference there that’s costing a few more fps over time.

The AI changes freqs and answers the ATC, It seems to be happening at the end of the AI answering…when you hear the squelch tail and when the AI changes freqs. I haven’t tried changing freqs or bringing up the window to respond myself.

I think you’ll find it’s less of an fps impact if you answer yourself. Seems to not make sense right, because your avatar’s voice still plays, but I noticed that after I turned off the AI pilot completely.

Thanks for your help with this. I will give that a try, but I wont keep it that way. I find the ATC lackluster and often times gives wrong approaches and very odd altitude instructions.

I listen to live ATC from the areas that I am flying by having this play in the background in my headset: . Give it a try. I find it very immersive.