Is it possible the sim is fine but rather it is our individual installations that are corrupt?

I’ve gradually come around to this theory. The problems all seem to be slight variations, there seem to be no two individuals with precisely the same exact issue. Although the vast majority do seem to have had a stable build at some point since release.

The installation process is unlike anything else I’ve ever encountered. The file download sizes are enormous and conducted over internet connections that seem to be throttled at source. Thereafter there is a decompression process whereupon the files are installed. It seems to me that there are an awful lot of opportunities for a data corruption to be introduced, and possibly not in the same way for everyone.

Rather than wasting time looking for something in the source code that isn’t actually there perhaps Asobo should release a tool that checks individual installations, if that is even possible. We all know that uninstalling a program doesn’t always get rid of every trace of the original installation and perhaps this is why people who do a complete reinstallation don’t find it helps at all?


I think you might be on to something regarding the CTD part of the issues. Surely, they have a checksum validation implemented upon decompression, so it shouldn’t be possible to corrupt during download/decompression without being caught. If they don’t have a validation implemented, they definitely should!!

Regarding the complete reinstall… yeah, an uninstall / reinstall of the sim definitely doesn’t start with a clean slate. One thing I definitely noticed is that my controller mappings persisted through a reinstall, so who knows what else persists. It hides files in quite a few places and not all of them are wiped when the sim is uninstalled. Definitely an opportunity for persistent bad or corrupt files to cause issues.

I highly doubt that these files would be responsible for the graphics downgrades, ATC issues, temp/altitude errors, etc… Those are truly new bugs… I mean features. :wink:

I do wish they could sort out the spurious reinstall all 124GB bug that is affecting people. I had it when coming out of the beta and also when going to the .14 hotfix. Doesn’t make sense, especially when the install folder is left at default (in my case).

Fingers crossed that they come up with at least some fixes in the near future. For me, the sim is still flyable but definitely not what it was before SU5.

If my system got corrupted then the update caused it. Before the update, everything worked, live weather worked; live traffic worked, the autopilots worked, ATC was marginal but workable, the graphics were excellent; and most of all there weren’t five or six CTD’s a day, every day, since the update–all for no obvious reason and happening randomly throughout the “experience”…

Some of the data - such as your controller mappings are not stored locally at all but in the cloud. I was pretty surprised to find my logbook and controller assignments all still there after a disk reformat and complete windows reinstall.

Of course, they also lost all our logged time a few months ago. I’ve clocked up nearly 150 hours sim time … for the second time, not to mention the rest :grimacing:

Yes, it was the CTD/freezing issues that I was mainly referring to. I haven’t even got to the stage of reporting any of the other peculiarities SU5 introduced to Zendesk, what’s the point when you can’t fly the planes?

Various ATC issues, no more percentages showing when you vary the mixture or prop, the GPS needle appearing to be different in 3rd person view than in the cockpit etc etc. These are bugs, as are the altitude temp issue while I guess the graphics “downgrade” will eventually become an issue of getting to a point where fewest people are complaining. The CTD thing though strikes me as being either some incompatibility that hadn’t been sufficiently tested or else a corruption at our end.

Interesting! I didn’t know this stuff was in the cloud too. I remember seeing some local files related to the controller mapping a long time ago. I guess they just pull them down from the cloud or check them at sim startup. Even though I’ve done some programming (firmware stuff and various other things), I’ll admit that this cloud implementation is way over my head. It’s a mysterious black box that we all seem to have to learn to live with.

Some data is stored in both cloud and local, controllers and your profile data (time flown etc.) are stored local and cloud. AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\SystemAppData\wgs for PC version and Steam is in the Steam folder in profiles.

Know exactly what you mean. The way MSFS is set up is something that I think is new to a lot of us. So much of the content and function is provided from the server end. I’m pretty sure that many of the graphical issues (FSX-like scenery, melted buildings etc.) are actually caused by server-side issues or bottlenecks and nothing to do with local installation, config or internet capability. Exactly how the local and cloud data merge and interact (if that’s the right term) is a secret known only to the programmers locked in the Asobo basement I guess!

It beggars belief that this is not already done no?
That some sort of file validity check is not performed as part of the download/decompress/install process.

1 Like

There was a forum post back in December that suggested there may be some involvement with a corrupted cloud save:

If this is so then it is appalling that some sort of fix has still not been developed.

Re. above link…and resetting profiles.

Recently there was a change to the way MSFS could be run. Previously it was possible to start the sim with the internet disconnected. I don’t think this is possible any longer and therefore the method described in the post above for resetting cloud based profiles may not work.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.