Is pre-caching still working?

Wondering if anything has been done to the pre-caching option lately. When first appeared the sim was awesome. No stutters at all. Now it’s entirely different. Stutters all the time.

Always had it set to Ultra, and no changes in my graphic-settings as I can remember.

i7 - 32GB - GTX 1070 - SSD

1 Like

I’m not having any issues with mine, but I’ve read its a good idea to delete it and rebuild it periodically. I did that after SU8 and it fixed a few issues for me.

1 Like

If I set it to anything other than Ultra, I get stutters when I pan the camera around, so it must be working.

There are topics with hundreds of votes about worse performance after SU9, so whether this setting has anything to do with it, I don’t know.

Hey @FrankTheMoose. I moved your post here to the #self-service:install-performance-graphics category where these type issues are discussed. Good luck finding the culprit.

1 Like

I turned it off in useropt.cfg when it was introduced, and have never had a studder problem with the sim. I have had times when Ive had studders, and switched it on and it did absolutly nothing at all here, and after shutting down and investigating further determined to be a network issue. So it stays off along with all the other ‘this will fix it’ caches. ;p

Is your VRAM usage with it disabled in the cfg file any different than it set to Ultra? Try comparing it using one of the preset discovery missions for a couple minutes (don’t press ready to fly). Or maybe I should just do this comparison myself. If disabling it in the cfg file is actually doing anything then VRAM usage should be less. I don’t want less VRAM usage.

I’ll do some research. Disabling it is probably a good start…

Hmmm…

Turned it off (LOW) and took a short trip around Miami, and it actually performs way better. Just a few micro-stutters now and then. Switching view both inside and outside the plane also is much smoother.

Didn’t change any other settings.

gpu 99-100% cpu around 50% with it off. You actually have to go into usercfg.opt and set both values there to 0, or it wont turn off. ie You cant turn it off in the menu’s you can only turn it down.

Of course the strange thing is, even with it disabled in the cfg file and that file being read only, in the menu in-game it still shows as being enabled.

But like I said it runs better here at 0 0 then it does 1 3 …

Not sure that it is working as intended. I seem to get better results when it is on the lowest setting.

I5, 48gb RAM, 2070S, SSD

I did 4 tests using the New York discovery flight and came to the conclusion that setting Enabled = 0 uses the same VRAM as Ultra no matter if the Quality value is 3 or 0 (Ultra or Low respectively). With Enabled 1 and Quality 0 (which means Low) I got less VRAM usage and more object pop-in, which is to be expected.

If you were running out of VRAM at higher settings then it’s quite possible you’d get better performance at a lower setting. In my case, where I’m not running out of VRAM, lowering it reduces my performance, as well as makes distant objects pop-in when I pan the camera.

If you were not running out of VRAM and Low performs better than Ultra, then the pre-caching setting is clearly broken.

My GPU usage is already good with it on Ultra. Higher CPU usage does not necessarily mean better to me, if the game is having to do more work swapping data in and out of VRAM more often. That’s wasted energy (and added heat, for what is potentially no real performance gain).

It could mean 1 or 2 things.

  1. The user interface wasn’t programmed to recognize the Enabled = 0 value
  2. We actually cannot disable off-screen terrain pre-caching (or 0 is just the same as Ultra)
2 Likes

Thanks for that.

I didn’t even know that pre caching was to help with low VRAM. At the moment the max VRAM I seem to use is just slightly less than 4 gb (out of 8gb) although tbh I don’t check it very often.

I did try disabling it once in a cfg file but that seemed to have adverse effects. Could have been ‘placebo’ though :+1:

1 Like

Thanks.

In my opinion, this pre-caching optimization is basically a Xbox-related optimization that came at the same time as the Xbox release of the simulator. I personally wish it never came to PC at all, but maybe it does help others with lower-end systems.

1 Like

It seems to work well for me, particularly when I’m flying regularly in the same area (I have some manually cached areas too.)

What I have noticed is that, irrespective of available bandwidth, sometimes if its pre-caching a new area, the servers aren’t sending the data to the PC quickly enough. This appears to result in the sim waiting for the data to be downloaded, written to the cache file and then read back into the sim from the cache, i.e. a stutter. Subsequent flights on the same route seem fine, because its reading directly from the cache on the SSD without waiting for data to be downloaded.

If the cache is turned off completely you may get less stutters because the data is fed directly to the sim, and not cached. However subsequent flights will use more bandwidth and be more susceptible to momentary drops in wifi etc.

It’s horses for courses tbh.

I thought he was referring to off-screen terrain pre-caching, not the rolling cache.

As far as the rolling cache goes, I have to delete it from time to time because it seems to cause severe stuttering issues for me. It might be that I didn’t have it set large enough.

Ah! that would make sense. Sorry all, it’s been a long day. :disappointed:

So, disablling the precaching on UserOpt.cfg is basically the same as having it enabled with ultra settings, correct?

Btw. I got better experience on medium or high setting, especially with panning in the cockpit.