Is there a guide to setting up the CS 777 FMC in MSFS 2020?

Hey everyone, just wondering if there was an FMC guide for the CS 777?

I have the salty-747 mod as well as the CS compatibility mod, however every time I plan a flight there seems to be a problem with the RTE page in MSFS. Either the waypoints don’t populate or they populate without speeds and even then sometimes the autopilot just refuses to follow them. I’ve tried using Simbrief and importing my legs, as well as the FP sync option in the salty mod to bring the flight plan in from the in game map but am still having issues. Does anyone else have this problem/has found a solution? I have tried waiting for the transponder to calibrate before requesting route data, but that still gives me similar problems. Other people have reported flying long flights with autopilot without a problem so I must be doing something wrong.

The default 787 seems to follow the FP just fine and speeds and altitudes are automatically added along with the waypoints.

Any help is much appreciated.

Is there even an FMC in CS add-ons?

Don´t worry all Boeings have the same FMC, you can watch PMDG 737 FMC or Asobo Boeing 747 FMC tutorials on YouTube. :slight_smile:

In all honesty I would not bother, unless you are using a mod. The default FMS isn’t very good at all. If you want FMS stuff go to the FBW A320 (Yes I know its not a Boeing) or use the Salty mod, I think you mod the Salty mod into CS Planes.

But an Airbus FMC is different compared to a Boeing FMC. I still don´t fully “get” the Airbus FMC. :smiley:
It is always best to learn both: the most professional and fully simulated Boeing FMC (with PMDG videos) and Airbus FMC (with Fenix tutorial vids.)

The knowledge one has learned on one aircraft type, like for example FBW or Fenix Airbus, can unfortunately not transfered to a Boeing cockpit and vice versa. That´s why it´s absolutely necessary to learn both FMCs and both autopilot variants.

Hahaha you make a good point. Even so I follow tutorials on youtube for simbrief and I seem to still run into the same problem. The waypoints either don’t populate or they populate without speed and altitude data. Any ideas?