Is there a problem with the ILS?

I haven’t been playing for a while and i made some flights with DC-6, Kingair, 747 salty and CJ4 WT, and I couldn’t make a successful ILS approach with any of them in the last 2 days. Glideslope or localizer couldn’t be captured at all. I haven’t such a thing

No problem here on the WT CJ4 or C172 NXi.

1 Like

Are you using the default sim Nav Data, or do you use Navigraph?

I am using default data

Which airports please.


Some aspects of the autopilot appear to be broken on that plane (at least in the version I am on SU8 beta). Please provide some airports as Gandalfuski suggested so that we can try to reproduce your issue.

I regularly use the DC6 and the Salty 747 mod.
Neither have any issues at all with the autopilot ILS
I have on occasion used the CJ4WT and have had no issues.
I don’t use the King Air much.

I wonder if this may be from an addon conflict.
Have you tried with the Community folder empty, and any 3rd party plug in’s external to the sim not used?

did u check to make sure the ILS frequency was added or was correct?

I am qıite sure that i entered the ils frequencies except 747. I assume ILS is set automatically when I select ILS approach from the FMC.
Actually, I don’t prefer messing up with the community folder but I will try if this is not fixed on my end.

Just rename the community temporarily. After the test you can rename it back.

Just tried the King Air ILS autopilot. The plane essentially landed itself, though not perfectly aligned with the runway, but close enough. However on the flight back, the autopilot NAV had severe issues and caused the plane to roll out of control twice, causing two stalls and a stress failure (v1.23.12). I could’ve switched off the AP and saved the plane myself, but I wanted to see whether the sim wanted me to crash and burn, and sure enough it did. Then, as I quit the sim to write about it on the forum, the sim crashed with an access violation exception.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.