Is there an issue with Bing Maps on Asobo's end?

Anyone else encountering some weird random sim issues today? I was using the sim for most of today with no issues and then a couple of hours ago a few odd things started happening out of nowhere.
First thing I did was remove everything from my community folder so it is now empty:

Bing maps data is no longer working - All Data options are turned on in settings and internet speeds are working as normal. The maps on the World Map screen are all blurry too. I checked manual cache and all maps are blurry there too. It’s acting like I have Photogrammetry off but i don’t. I tried signing out of Xbox live and back in, no change

The Drone camera speed - It no longer changes. I put it up to 100 and it’s still the same speed. I put it to 0, in which it shouldn’t move at all, but still moves at the same speed.

Both of these issues above started at the same time. No new addons were added or any other changes made prior to the issue. Here are some pics of the issue:

5 posts were merged into an existing topic: No streaming data working, photogrammetry and bing maps just stopped working

A vote has been moved.

Hi @Dmajestic80!

I’ve merged your post into another topic about the same issue that has more votes, so that we can keep all responses to this issue together and importantly so votes don’t get split between the two. Feel free to continue the discussion over on that thread.


1 Like