Is there anyway to configure a joystick POV to do both trim and views?

I’m looking to pick up the Thrustmaster TCA (stick + throttle) but I noticed there is only one POV. In my current setup, my joystick has a POV, which I use for Elevator/Aileron trim. The seperate throttle has a POV as well, which I use for views…Free look, and I have a button next to it, to reset the view forward. It’s handy as I keep both hands HOTAS style without having to use the mouse to look around…

To finally get to my question…Is there anyway, in game, I can have a single POV do both? I’m thinking trim is default and maybe holding down the trigger on the joystick, the same POV could switch to free look…

If I recall you can use a registered Fsuipc7 to configure a ‘shift’ key, it is demonstrated in the fsuipc7 docs. I’m not at my pc just now so can’t be sure.


You don’t need FSUIPC or anything like that for this.

Just decide which button you want to use as a “shift” key and make sure that it’s not bound to anything.
Then, when you bind your hat to an “alternative” function, press and hold the “shift” button followed by the hat movement. Release them in reverse order.

If you got it right, the binding will be listed as + .

Unfortunately, the limitation is that you cannot have the “shift” button on another device.

You basically answered your own question right there. This works fine within the sim. You don’t need FSUIPC or anything else for this.

All the replies here are correct.
But bear in mind, FSUIPC does so much more than just add a shift function.

Yeah, I’ve tried what I mentioned…I can press the trigger, and while keeping it pressed, click say left POV for look left. In SIM, it does register as “button+pov left” and it’s listed as such. Testing it there, it works. When I return to the sim though, just clicking the trigger alone, moves the vew left without the POV being touched…I’ll go back in and try again…

Strange that it’s not working. I have a crapload of shift functions on my Honeycomb and they work fine. Had a bunch on my x56 stick prior and no issues there either.

Did you unbind the commands you previously had on your trigger? Your shift key is best left unused for any other purpose than being a shift key.

I did remove the other key bind that was on the trigger (I had it set to show/hide the ATC menu) but still no luck. Like I mentioned, I can see them listed in the controls as trigger button + pov (left, right, up, down) and clicking the combo in the controls, they work. But in sim, I just get look left as soon as I press the trigger without any modifiers. The only strange thing I noticed is I have to keep the trigger pressed down, then select a POV direction at the same time, and keeping those both pressed, click on validate to get the combo to register. I’m thinking my problem might be the trigger being used as a “shift”…The sim doesn’t like it…I’ll try a different button plus the POV to see if that makes a difference…

Have you just tried to use a couple of buttons on your joystick for your trim up/and down settings? I have a hotas and on the joystick pov is pov buttons 3 and 4 are trim up and down and buttons 11 and 12 are trim left right. Works just fine here that way…

But what if you try “but7+but11” and “but7+but11” for rudder trim? In my case when I use a combination like this and press “but7+but11” to trim the rudder both trims - rudder and aileron activate.

Ok, I figured it out and have it working the way I want…after trying some things. Apparently, in my case or it’s just something I didn’t realize is, when doing a combo/modifier and a POV button is…You select the POV direction first, then the modifier, not the other way around…Modifier then the POV direction.

Now, the POV alone controls elevator / aileron trim. If I hold down the trigger, then use the POV I can free look left/right/up/down…Perfect!

Thanks to everyone for the clue about the modifier!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.