Issue after updating to 1.15.8 - Crash to Desktop every time

,

First off, loving this version of MSFS big time! I’ve been a huge sim fan forever and and this is by far the best. Congrats to Asobo for such a great product!

But I have an issue today. I’m posting it here because I’m not sure where to post it. Please let me know if there’s somewhere else this should go.

After downloading the 1.15.8 mandatory update, I can no longer load into the game. I crash to desktop right about when the progress bar is a about 80-90%.

I’ve run all the latest Windows updates, and have updated my video driver.

My Community folder has been emptied and I still am unable to load the game. I even rebooted my PC.

I have the GamePass edition.

Is there anyway to roll back to the 1.15.7 version to confirm that it’s the update that is causing the problem? Was working fine yesterday.

This is the only info that’s showing in the error log:

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60783c14
Faulting module name: VCRUNTIME140.dll, version: 14.28.29231.0, time stamp: 0x5f4c66c9
Exception code: 0xc0000005
Fault offset: 0x0000000000001550
Faulting process id: 0x3c10
Faulting application start time: 0x01d733ba759ae929
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
Report Id: 15a32281-0dc1-4701-8aa1-346253e455e0
Faulting package full name: Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

I have gotten the VCRuntime error as well.

The only way I can get the software to run reliably is to have a completely empty Community folder, with one exception: Navigraph.

Every time I have tried to install any mods I get a CTD before I even leave the runway.

I have the MS Store edition, and have run the “Repair” option found under “Advanced Options” in the Apps menu.

Uninstall KB5001330 if you installed it in the last few days.

I’m having the same issue since this update too. Sometimes crashing within 20 min flying, and sometimes when loading the flight.
I’ve already emptied my community folder, unistalled this KB5001330, disabled V-sync, optimized on Nvidia Experience and nothing really solved.

I simply just don’t know what to do. This isn’t the first time this game turns me really frustrate.

My specs:
i7 4770
16GB DDR3 1600mhz
RTX 2070

I played this sim for 300 hours without any CTD. Now I almost can’t go into a flight…

1 Like

Hey,

Did you find a solution to this? I’m getting exactly the same issue as you described…

I’m starting to wonder if it was the windows update last week (around the 13th). I’ve had 0 CTD’s since launch. Now it happens every single flight, besides with the piper arrow for whatever reason.

9600K OC
2070 super
32gb RAM

I can’t even get that far. Instant CTD at ~75% progress at the title screen loading bar. Used to be able to play with no issues but after downloading the latest world content update the CTDs have started. Opened a ticket with MSFS Support so fingers crossed

1 Like

The problem may be in USB devices.
On/Off USB=CTD
Check your connected Bluetooth devices.