Issue of MSFS2020 with HP Reverb G2

Hi all,

I am new to this MSFS2020 and this forum with the following specification:

CPU: i9-109800xe
Motherboard: Asrock X299E-ITX/AC
Memory: 32GB + 12GB
GPU: MSI Radeon RX 580 ARMOR 8G OC

Ok, I run MSFS2020, load saved game and click ‘Ready to Fly’, I switch to VR mode when flying, the screen of MSFS2020 just keeps blinking and the screen of Windows Mixed Realty keeps flashing with glowing sound. Anyone know how to fix it? Thanks!


you could try unplugging the power to your g2 headset , restarting the computer, and only plug it in after msfs2020 starts. I think most people close down windows mixed reality, start msfs, and then wmr will autostart when VR mode is selected within the game.


Thanks for your reply. I tried your suggestion but it still cannot resolve the problem.

As long as I swith to VR mode within MSFS2020, WMR will autostart and the flashing also starts. WMR will return to normal if I close MSFS2020. I wonder what trigger this problem.

Hope anyone had come across this issue could guide me to resolve it.



I was having this same problem with my Reverb G2 last night. I just got it and this is the first time I’ve tried using it for MSFS, but other games (Elite Dangerous, Squadrons) have been working just fine.

CPU: i5 4570
GPU: GTX 970
Memory: 24GB

I have the OpenXR app installed and configured according to the guide, custom render scaling is at 60. Once it started doing this it stopped responding to all input and I had to alt+F4 out of the program which made iterating on the issue time consuming. I tried it off a fresh boot and it still had the same issues.

I’m playing from within the Xbox app, not the Steam version, so it’s not using SteamVR. OP are you running the Steam version or the Windows/Xbox store version?

Hi, Im running MSFS2020 from Windows / Xbox store version.

Hi all,

I upgraded my video card to Inno3D 2080 Super but still having the same issue. I really don’t know how to fix it.

Anyone able to resolve the problem? Is this problem just for Reverb G2 or also happens to Q2?


Updated. I checked all my setting in MSFS2020 and found that the Data setting was set to OFF. So, I enabled Data to ON and some kind of out of date message and forced to log me out from Xbox. After I logged back my account and it detected an update for about not more than 200MB.

After the update, I tried to switch to VR mode when flying, WMR autostarted and now WMR windows without flashing screen and glowing sound…however, MSFS2020 turned to black screen. If I close WMR, MSFS2020 screen returns to normal. I think something wrong with the update yesterday.


I haven’t had any sort of issue like you are having. I’m on a 5900X, 3090, G2 with MS Store version.

Do you have the latest Open XR installed? What is your Virtual memory (page file) set at? With only 24gb physical you will need at lest a 48gb page file. You are only getting 35pfs in 2D make sure your 3D settings are cranked way down to start with. In Open XR set the slider to no more than 70%. Can you start 3D in the menus before you start flying? Start on the ground at a desolated airport (small airport in the middle of nowhere)

Tricks that work for me.

  1. Use a remote controlled power plug on the G2.
  2. Turn G2 on before launching FS.
  3. Close the WMR window.
  4. Start FS.
  5. Hit the \ to start VR.
  6. don’t close the WMR window this will shutdown 3D.

There are some registry keys that involve picking the correct render pipeline that you might need to tweak. I’ll see if I can’t find them.

1 Like

Oh I kind of mixed the two posts together. I see one of you has done some of the suggested stuff and other maybe no.

Ok, no further development but just want to share what happened when I switch to VR mode now.

When I switch to VR mode in main screen, VR mode is working ok, however, when MSSF2020 lodges to ‘Ready To Fly’ screen, VR mode not working and MSFS eventually shuts down.

Anyone know how to fix this? Thanks!

1 Like

I had exactly the same problem since yesterday. I used VR in the sim without problems in the afternoon 3 hours. All perfect with my reverb G2. I changed nothing on my high end pc system.
In evening I restarted my pc, opened msfs 2020, loaded a flight plan and in game switched to vr, like however, …and got the same issue like you.

Maybe again a damned update in the background ?

DCS and all other games working fine, so it’s not a problem of the reverb G2. Nothing changed on msfs 2020, nothing changed on WMR or other -for VR- necessary programs.
But good to know that I am not the only one who have this issue. I already get crazy with this VR in the sim. I tried yesterday all in settings etc. …but now I have no idea anymore. Again VR must wait…will see what next big update will bring (maybe more problems). Very frustrating…

I’m unsure if a recent update fixed it or if it was something I did differently, but I set my Render Scaling down to 50% and started VR mode while I was still in the menus. I planned and launched my flight from the “white room” and was able to load in just fine this time. Once I was loaded in I was able to turn my render scaling back up to 80%, though at a significant performance loss as the gtx 970 isn’t exactly a beast of a card. New system can’t come soon enough!

Somewhat related note: Landing in the dark is SO much easier in VR.

I recently resolved the issue by switching V-Sync to off. Anyone please try. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.