Issues after last update

Got the same problem with freezing and not responding at all. Only way is to close the Sim via Task Manager.
I found out it happens when Free Look Togggle is activated by clicking Center Mouse Button and then using the POV Switch on the Joystick to go to the next Pilot position.
Tryed it with VL-3 and C172, empty Communtiy Folder.
Anyone else experiencing this sort of Freeze?

Its been on this page for 2 hours now. Time to call it a day, again.
Now I have reset the cache for windows store, xbox app and updated my bios. Its microsoft / Asobo issue now… I have to request a refund, its ridiculous…

This just works for the constant CTD’s I had. Flightsimulator.exe crashing while loading the game, importing a flight plane, browsing airplanes, on the ground in cockpit, during a flight at random stages of the flight… Flight which never exceeded 2 to 10 minutes if I got lucky enough to just take off. Barely had 2 or 3 crashs all together before this “hot fix”.

I’ve tried everything I could imagine; rolling back to various versions of nVidia GRD or Studio drivers, verifying all updates on my system, disconnecting usb peripherals and so on. Even tried a full re-install of MSFS which got stuck in a loop of downloading/decompression for nearly 15 hours; good for me I made a backup of the installation folder before trying the re-installation.

Disabling the device “Sonic Studio Virtual Mixer” in the Windows device manager is the solution. No more CTD’s at all. Did a 4h+ flight and many other tests without any problem. And no more crash during loading or UI manipulations.

Considering that Asus mainboards are widely used in home build pc’s or gaming laptops there is no doubt that many users reporting constant and random CTD’s are affected by this problem. How this kind of total game breaking “bug” on such a popular brand of pc hardware can go through QC and making the product totaly unusable for the customers (we are customers before being users) is another story…

It might be a good idea to create a separate thread with your workaround. It certainly will help plenty of people.

Thank you a lot for your solution.

1 Like

Somewhere in here must be a chicken and an egg … It happens a lot, two developers outputting what they think is perfection only to find that together they don’t work.

Haven’t even been able to get in to the game again after update. I vaguely remember a recommendation to backup the community folder after joining the beta BUT I didn’t expect Asobo to willy-nilly delete files of my computer.

Surely you could throw up dialogue stating files +100gb of files will be deleted in order to update and give people an option, to help people to not have miserable experience. It’s so ■■■■ frustrating.

I now have to manually try to restore my community folder based on my memory, and puzzle back together repaints… :rofl:

Again I think it was recommended but I didn’t think they would delete the whole game from my hard drive without communicating it first…

A spreadsheet with all the relevant data about the addons, is a great help, as I do not rely anymore on my memory. :rofl:

In future move your C&O folders to a new location and update the new path in UserCfg.opt, this way MSFS cannot delete them automatically. To save having to download the official files again at update be careful to point to the folder containing them when asked. e.g. if you placed them in a folder directly on your D drive called MSFS2020 the path would read D:\MSFS2020

now… I assume that the testers have not these useless asus tools installed , ergo → no crash :joy:

It is like we mentioned million of times now, a developer company can never ever test all existing hardware/software combinations…

At least, also as already mentioned, the official FAQ mention these tools since a long time as “causing conflicts”.

Whether realy the patch caused the new issue, or some silents updates of these sound-driver-stuff, we are not 100% sure about.

Hello everyone,

I am very sorry, but I cannot find how to create a new topic for my problem.

I invested in a new gaming PC for Christmas, 2,600 € to be able to play Flight Simulator in good conditions.

Ryzen 5 5600X
16GB RAM (2x8)
10GB NVIDIA GeForce RTX 3080

The game crashes on startup! Impossible to play there.

The game launches, the studio announcements go through, then the game connects to Microsoft (I deduct it because this is where I connected the first time), the small loading circle rotates for 5sec at the bottom right then the image blurs and returns to the desktop.
No error message or code etc … (only error message during the next launch asking me if I want to launch in “normal mode” or in “safe mode”) I have also tried both, but it’s the same.

I followed all the guides and advice on the internet for game crashes, nothing works.

I specify that I took it on Steam. So the manipulations specific to Microsoft, Xbox Store etc … I did them too, but little chance that it will have an impact.
Besides, I had my game refunded on Steam to take it on the Xbox Store thinking it was due to a Microsoft account problem. Nope, same problem.
By force, everything broke and it was impossible to reinstall the game via the Xbox app. So I got it refunded again on Xbox Store and I took it back on Steam since there, I managed to install / uninstall it.

I tried to install it on my second hard drive, activated deactivated my software, added Steam (and the game when I could) to the software exceptions, activated deactivated the VPN, launched the game without internet connection, installed another software free for test, logged in, logged out of Microsoft account, …
I even managed to find the Driver of an old version of the NVIDIA driver (which would be more stable) but no, it has no effect.

I am totally up to date with Windows updates (even secondary ones), NVIDIA drivers, etc.

I am exhausted ! I tried everything I could and found on helpers, guides, forums etc … absolutely nothing works.

How to do it please?

Not a useless tool from Asus, it’s not a program. It’s part of the audio driver which it seems (I did not investigate further), manages the mic in from the mainboard and it has not been updated. I don’t have Asus Sonic Studio installed neither. The only way to avoid the problem is to disable this part of the sound system from the mainboard in the device manager and, I presume, loosing the mic in from the mainboard. It is hardware related, hence my comment. I disabled the Nahimic service and the ctd’s continued. Like I said, I had barely 2 or 3 ctd’s until this hot fix, very stable, nothing to complain. As for the list of incompatible softwares in the faq, in nearly 4 decades of using various operating systems and softwares I have never seen such kind of list.

1 Like

Have you tried the solution posted by ShierLattice199 ? Since you have an Asus mainboard I suggest to check your audio devices in the Windows device manager and look for a device named “Sonic Studio Virtual Mixer”. If present disable it. Worked for my Asus mainboard.

Or rightclick on your speaker icon in the taskbar, go to → sound settings and look for a device ’ Sonic Studio Virtual Mixer’.
Disable it.
I neither have Asus Sonic Studio installed

It is a fine hardware setup you have, hope to see you soon in the virtual skies :smiley:

I don’t have “Sonic Studio Virtual Mixer” :roll_eyes:

Usually safe mode only gets offered if you have mods in your community folder so I would at least try without. However if any mods came with an installer that might not be enough and you should uninistall them with the provided uninstaller or in Windows settings. And to cap it all even that might be enough as 3rd party marketplace addons can also cause issues. It is always worth looking in known issues first but otherwise deleting these mods in the content manager is the only surefire way to eliminate them as a problem. Hopefully a disable button is on it’s way soon.

ähmm… nope… in case it crashs the file “running.lock” will not be removed and this is the trigger for the game to show the choice “normal mode / safe mode” . You can simple place such a file manually in case you need the safe mode for a test-case :slight_smile:

@Sway13500 in case of ctd you can see a message in windows event log… may be its helpfull.
Did you tried already to remove rolling cache file manually ( “%AppData%\Microsoft Flight Simulator\ROLLINGCACHE.CCC” ) ? And also re-login in xbox app ( restart in middle ) ?
May be, because you own realtek device, disabling the nahimic service may helpfull ( not allways the case ). And of course we assume for testcases an empty community folder and no OC…
In case you had former installed these google maps addon, please check the hosts file - these add-on do horrible changes.

Thank you very much.
I deleted the ROLLINGCACHE.CCC file but it had no effect on the game crashing.
My audio system is realtek. I thought I saw nahimi files somewhere, but following this quick guide:
youtube : watch?v=dAregRet7p8

There is no “nahimic service” in my settings.
Capture d’écran (41)

On another forum, someone advised me to reinstall Windows because I installed/uninstalled the game too much, the registry would be wrong.
And start the game immediately before installing anything on the computer.

I also don’t have Google Maps installed on my computer.

you opened “msconfig”, right ?.. I remember , strange as it is, within this ‘dialog’ was nahimic also not listed in my case. Easier for a first test would be to open “services” instead and in case you find nahimic, just disable it. I removed these “stuff” in meanwhile manually completly from my pc and so I can not show you a current screenshot… but I found an older image :slight_smile:

( note: if you follow the link and the discussion, there is also an image about how you find “services” )

Another possible idea to test whether your ctd is caused from your sound-drivers can be to stop the “windows audio service” ( also within “services” ) . In this way you disable whole sound and if in the test-case then msfs will start fine, there is high chance that issue comes from audio.

Otherwise we need to think about other reasons… e.g. it may have somewhat todo with the refund and possible stored cloud data… then we have to clean this.

And have you found the “windows event log” message ? ( quick howto )

I just reset my whole PC.
I only installed Steam and Flight Simulator.
The game crashed again in the same place.

PS: I’m going to open another topic for my problem because I think it’s going to be long, it’s crazy!

Thank you very much everybody.

I am French and my Windows was only in French! We need to install the English (United States) language pack to install the game because it was only in English at the time.

I had already visited the website that advised this procedure, but in the mental state in which I was (that is to say disappointed) I passed too quickly on it and I did not pay attention to it.

The game is installing.

I should definitely look for solutions later in view of the many problems shared by the community every day.
But I’m so happy that this problem that was driving me crazy because I didn’t understand how it was possible with a completely new computer, is solved.

1 Like

Guys, sorry for the late solution but I solved my issues by performing a complete windows reset :grimacing:

1 Like