Issues with MSFS 2020

I have the sim running okay and downloaded the Alaska Bush Trip challenge. All seemed fine till I went to run it and it gets to the point showing the legs of the trip on screen and I click to load it and it gets to about I’d say 75% and then MSFS shuts down. Tried to restart computer and sim, shows update screen as usual but nothing gets updated. Same issue. Also downloaded the World Update USA file and have downloaded most of the minus a couple cities. The file that is the USA Points of Interest I’ve tried to download 3 times now and it gets to where it shows on the progress bar that its finished except it shows an error and on the info tab it says I need Game version 1.11.5
Now I did download and install that FSUIP for 2020 and installed it as I was going to do some other scenery things which I havent got around to yet plus I did install a couple of those map programs. Not sure if this has anything to do with all of this. Dont know why the bush trip keeps shutting down the sim and why this Points of interest wont install.