I've joined the beta but no new version proposed

Hi team,
After leaving the beta for a while, I joined it again last Friday.
But since, I am still in 1.29.28.0 without being able to download the SU11 beta update.
I’ve tried disconnecting from Xbox, MS Store etc… to no avail.
Any clue?
Thanks!

Did you follow the below?

Beta Testers: New Information on Joining/Leaving the Beta - Community / News and Announcements - Microsoft Flight Simulator Forums

Yes, sure! :wink:

Hi after joining the beta from the xbox insider hud you might need to do a full pc reboot then reopen the xbox app to start the update,

Thanks
Andy

Hi there, checking in wit you to see if you were able to get the build upon a hard restart and logging out/into your apps?

Thanks, Andy but it doesn’t work.

Hi Jane, I’ve tried all possible solutions without success.
I’ve been in the beta loop since the beginning and never had this problem.
Very weird.

1 Like

I’ve tried again, logging out/into MS Store and XBox, joining/leaving/rejoining the beta, rebooting the PC between each step, etc…
No luck.
I’ve been asked to give some professional feedback on the A310’s new build, but I can’t, unfortunately.

Hi Jane,
Should I open a ticket @zendesk or you can help me on your side?
Thanks!

Is there any kind of official support on this forum?